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АННОТАЦИЯ 

 
В курсе семинаров будут рассмотрены основные темы курса «Автоматическое 

проектирование ЭВС», посвященные практическому проектированию печатных плат в среде 
PCAD 2002. 

. 



ВВЕДЕНИЕ 

Данный конспект семинаров составлен на основе курса семинаров (по проектированию 

печатных плат в САПР PCAD 2002), читаемого в МГТУ им. Н.Э. Баумана на кафедре ИУ4 

преподавателем Назаровым А.В. Курс лекций рекомендован к выполнению текущих 

аттестационных мероприятий и подготовки к экзамену по предмету «Автоматическое 

проектирование ЭВС». 

 
. 
. 
 
. 
. 
. 



CОДЕРЖАНИЕ 
ВВЕДЕНИЕ………………………………………….………………………………………….……..…...……..6
1 МАТЕРИАЛЫ СЕМИНАРОВ ПО КУРСУ………………………………………….……..…….….7 

1.1. Разработка шаблона символа………………………………………………………………………7 
1.2. Разработка символов микросхемы К511ПУ2…………………………………………………….8 
1.3. Разработка шаблона посадочного места…………………………………………………….…...10 
1.4. Создание стеков контактных площадок (КП)...…………………………………………………11 
1.6. Разработка посадочного места DIP-14...…………………………………………………………13 
1.7. Запись БЭ - К511ПУ2 в библиотеку ………...…………………………………………………...14 
1.8. Разработка символа для ИМС 133LA6. ……...………………………………………………….15 
1.9. Разработка ПМ PLAN –14 .……………………………………………………………………….16 
1.10. Запись БЭ - 133LA6 в библиотеку  .……… ……………………………………………………17 
1.11. Разработка БЭ -  диод  KD403A. ………………………………………………………………..18 
1.12. Разработка БЭ - транзистор KT3102G. ………………………………………………………...20 
1.13. Разработка БЭ - клемма GND. ………….………………………………………………………22 
1.14. Разработка БЭ - соединитель ON-KS-10. ………………………………………………………23 
1.15. Разработка БЭ - резистор C2-33. ……….……………………………………………………….25 
1.16. Разработка БЭ – катушка  D1-1,2-1. …….……………………………………………………...26 
1.17. Конденсаторы  K10-43A   и K73-15 …….…….………………………………………………..27 
1.18. Разработка   форматки  для Э3 ………….…….………………………………………………..29 
1.19. Разработка электрической схемы ……….…….………………………………………………..31 
1.20. Разработка схемы с иерархией………….…….……………………………………………..…..34 
1.21. Ввод схемных обозначений по ЕСКД  ……….…………………………………………….…..36 
1.22. Вывод схемы на принтер ………...…………….………………………………………………..36 
1.23. Разработка шаблона печатной платы   ……….………………………………………………...37 
1.24. Поиск элементов в библиотеках …..………….………………………………………………...38 
1.25. Перенос проекта Э3 в проект на ПП ………….………………………………………………..39 
1.26. Ввод базовой конструкции ПП ……………….………………………………………………...40 
1.27. Ручное размещение проекта…………….…….………………………………………………...40 
1.28. Ручная трассировка проекта………………….……………………………………………….....41 
1.29. Введение вершин изгиба проводников……….…………………………………………….…..43 
1.30. Режимы ARC и Tangent ARC………………….…………………………………………….…..44 
1.31. Сглаживание изгибов проводников ………….…………………………………………….…..45 
1.32.  Полуавтоматическая трассировка …………….…………………………………………...…..45 
1.34. Внесение изменений в проект………………….………………………………………………..46 
1.35. Металлизированные отверстия для МПП…….………………………………………………..48 
1.36. Создание  областей металлизации …………….………………………………………………..49 
1.37. Ввод текстового описания схемы …………….…………………………………………….…..50 
1.38.  Оптимизация цепей (Swap Gate). …………….………………………….……………………..51 
1.39. Копирование элементов библиотек ………….………………………………………………....52 
1.40. Программа SPECCTRA – начало работы…….………………………………………………..53 
1.41. Размещение ЭРЭ с помощью ГИП…………….………………………………………………..54 
1.42. ГИП - режим трассировки. …………………….………………………………………………..57 
1.43. Ручная корректировка трасс... ………………….……………………………………….….…..60 
1.44. Выполнение отдельных элементов ПП………….…………...………………………………….61 
1.45. Трассировка МПП. ……………………………….……………………………………………...63 
1.46. Выбор символа из проекта в библиотеку ……….……………………………………………..63 
1.47. Программа Design Manager …………….……….………...…………………………………….63 
1.48. Выпуск конструкторской документации……….…………………….…………………………65 
1.49. Дополнительные сервисные функции ………….………………………………………………67 

ДОПОЛНИТЕЛЬНЫЕ МАТЕРИАЛЫ……………………………………………………....……...………..69 
 



1. Разработка шаблона символа           
Символ – это элемент электрической схемы. Шаблон – это файл c выполненными 

настройками параметров проекта. Шаблон символа  создается в следующем порядке. 
1. Запустить редактор символов командой Пуск > Программы > PCAD 2002 > Symbol Editor. 
2. По команде Options > Configure: установить метрическую систему (Units = mm), 

нажать User и установить ширину листа (Width=110) и высоту листа (Height=70),  
далее установить флажки в поле Orthogonal Mode, чтобы при черчении линии ко-
мандой Place > Line выбирать (клавишей «О») все направления рисования линии. 

3. После Option>Block Selection установить все флажки в панели Items и верхней флажок 
в панели Select Mode, – все объекты будут подчиняться команде Option > Select. 

4. Ввести сетку чертежа = 1,25 мм: после  Option>Grids  ввести Grid Spacing=1.25 и щелк-
нуть левой клавишей мыши (LB) на кнопках ADD и ОК (аналогично ввести сетки, 2.5 мм, 
5.0 мм и 0,25 мм). Установить флажки в полях Visible и Dotted (видна точечная сетка) и 
нажать кнопку OK; клавишей «Х» установить форму курсора в виде прямого креста. 

5. Ввести ширину линии = 0.6 мм: после Option>Current Line в окне User  ввести зна-
чение 0.6 и нажать OK – введена ширина 0.6 мм (аналогично ввести значения 0.4 и 
0.2 мм). Командой Place > Line нарисовать по одной линии каждой ширины. 

6. Ввести в проект шрифт высотой 2,5 мм (11 пунктов) этапами:  
 после Option>Text Style>ADD ввести Style Name = 2p5 и нажать OK; 
 в окне Text Style Properties нажать:  Allow True Type > True Type Font > Fonts; 
 в открывшемся окне Шрифт установить: Шрифт = Arial,  Начертание = Курсив, Набор 
символов = Кириллица,  Размер = 11 пунктов и нажать OK  >OK > Close; 

 аналогично создать шрифты 3,5 мм (16); 5 мм (22); 7 мм (31); 10 мм (44 пункта); 
 командой Place > Text ввести в проект произвольный текст – имя каждого шрифта. 
7. Настроить  горячую клавишу Backquote (слева от клавиши 1) для выполнения ко-

манды  View>Extent, для чего после: Option>Preference>MenuCommand щелкнуть LB 
на строке View Extent в поле MenuCommands, перевести далее курсор в поле Press a 
Shortcut Key, нажать клавишу Backquote и щелкнуть LB на кнопке Assign. 

8. Командой Symbol > Save To File As записать шаблон  на диск под именем ShablonSYM. 
9. Покинуть редактор символов по команде Symbol > Exit. 
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2. Разработка символов ИМС К511ПУ2             

Микросхема К511ПУ2 содержит 2 символа NOT–AND «НЕ с расширением по И» 
(рис.  1-a) и  два символа 2AND–NOT «2И-НЕ» (рис.  1-b). Нумерация выводов симво-
лов на рис.1 указывает порядок их создания. В корпусе К511ПУ2 (рис.2) символы 
NOT–AND занимают секции 1 и 2, а символы 2AND–NOT – секции 3 и 4.  

Символ NOT - AND создается в редакторе Symbol Editor в следующем порядке. 
1. Загрузить шаблон Symbol > Open > ShablonSYM. 
2. Сохранить символ на диске в файле NOT– AND командой Symbol > Save to File As. 
3. Построить условное графическое обозначение (УГО) символа NOT–AND этапами: 
 по команде Option > Grids в поле Grids дважды щелкнуть LB на строке 2.5 – сетка с 

шагом 2,5 мм станет текущей; 

 

a) b) 

          Рис. 1                                                                                    Рис.  2 
 установить линию шириной 0,2 мм, выбрав ее в поле Line Width строки статуса; 
 активизировать команду Place > Line, переместить курсор в точку  20/10 (с этой целью 

набрать с клавиатуры: j 20 Tab 10 Enter ) и щелкнуть LB (либо 2 раза нажать клавишу 
«пробел») – курсор примет форму косого креста; 

 клавишей «стрелка вправо» переместить курсор в точку: 35/10. и 2 раза нажать «про-
бел» – будет построена горизонтальная линия – нижняя сторона УГО символа;  

 перемещая стреками курсор в точки  35/30,  20/30 и  20/10 , дважды нажимать пробел 
после каждого перемещения, после чего – щелкнуть клавишей Esc (рис.  3).  

4. Сформировать выводы символа NOT–AND этапами: 
 по команде Place > Pin в окне Place Pin установить: User = 5 мм, Default Pin Name = Е, 

Default Pin Des = 1, поля Increment Pin Name и Increment Pin Des – сбросить; 
 нажать OK и, переместив курсор в точку 20/15 , щелкнуть LB и RB – рис.  4; 
 щелкнуть LB в центре экрана, ввести: DefaultPinName = In, DefaultPinDes = 2, нажать  

OK и щелкнуть LB и RB в точке 20/25 . – рис.  5 (выводы слева); 
  щелкнуть LB в любой точке и установить поля: Default Pin Name=Out, DefaultPinDes= 

3, Outside Edge = Dot,  щелкнуть Ok, нажать LB в точке 42,5/25 , и, не отпуская LB, 
дважды нажать на клавишу R, отпустить LB и щелкнуть LB; 

 поставить цифру 3 над выводом: после Edit > Select при нажатой клавише Shift щелк-
нуть LB в центре цифры 3, отпустить Shift, нажать LB и перетащить цифру наверх (над 
выводом), после чего – отпустить LB – рис. 5. 

5. В точки: 15/15, 31,25/31,25 , 31,25/8,25  ввести точку привязки символа, место под 
обозначение элемента, (DD4 и пр.) и место под тип элемента (К155ПУ2), этапами:  

 после Place > Ref Point щелкнуть LB в точке  15/15 – введена точка привязки; 
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 после: Place>Attribute>Component>RefDes установить поле: Text Style={PartStyle}, в 
поле Justification выбрать точку в центре, нажать Ok (курсор примет форму косого кре-
ста) и щелкнуть LB  в точке  31,25/31,25  (рис. 6 – верхняя надпись). 

 после: Place>Attribute>Component>Type установить: Text Style={PartStyle}, в поле Justifi-
cation выбрать точку в центре, нажать Ok и щелкнуть LB в точке 31,25/8,25 – рис.6. 

   

Рис. 3 Рис. 4 Рис. 5 Рис. 6 
6. Создать библиотеку Test, для чего после Liblary > New в окне Liblary New в поле 
Имя файла ввести имя Test и щелкнуть LB на кнопке Сохранить. 

7. Записать созданный символ в библиотеку Test под именем NOT–AND этапами: 
 подключить библиотеку Test, для чего после Symbol > Save As в окне Symbol Save to Li-

brary, нажать кнопку Library, выбрать библиотеку Test и нажать кнопку Открыть; 
 в поле Symbol ввести имя NOT–AND, сбросить все флажки и нажать Ok. 
8. Командой Symbol > Save to File As сохранить символ на диске под именем NOT-AND. 

Символ 2AND–NOT создадим на основе символа NOT-AND этапами. 
1. Командой Symbol > Save to File As сохранить символ на диске под именем 2AND-NOT. 

Поменять местами выводы E и In (рис.7), после чего щелкнуть LB и, затем, – RB  в 
центре вывода E. В меню выбрать строку Properties и далее в меню Pin Properties 
установить поле: DefaultPinName = InA и щелкнуть LB на кнопке OK – рис.  8. 

2. Щелкнуть LB и RB  в центре вывода In, выбрать строку Properties и установив поле: 
Default Pin Name = InB, щелкнуть LB на кнопке OK – рис.  9. 

3. Записать символ в библиотеку Test под именем 2AND-NOT (п.8 раздела 2). 
4. Командой Symbol > Save to File  сохранить символ на диске. 

   

Рис. 7 Рис. 8 Рис. 9  
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3. Разработка шаблона посадочного места  (ПМ)       
ПМ – это конструктивные элементы (металлизированные, крепежные отверстия, пара-
метры масок, маркировки, графика сборочного чертежа), предназначенные для монта-
жа электрорадиоэлементов (ЭРЭ) на ПП. Рассмотрим порядок создания шаблона ПМ. 
1. Запустить Pattern Editor и после Options > Configure установить: метрическую систе-

му, ширину (Width=100) и высоту (Height=70) листа, флажки в поле Orthogonal Mode, 
2. Установить шаг сетки чертежа 2.5 мм: после Option>Grids в поле Grid Spacing вести 

значение 2.5 и нажать ADD. Аналогично ввести сетки 0.25, 5 и 1,25 мм. 
3. Ввести шрифты и выполнить назначение «горячих клавиш» (пп. 6 и 7, раздел 1) 
4. Записать шаблон на диск как ShablonPRT, по команде Pttern > Save To File As. 
5. Покинуть редактор по команде Pttern > Exit. 
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4. Создание  стеков контактных площадок (КП)        
Введем обозначения: N-неметаллизированная; С-круглая; М-металлизированная; T-

сквозная; Р-планарная; R-прямоугольная; латинская «p» заменяет десятичную точку.  

Стиль TN6p0-2p7С  - крепёжное отверстие создается как компонент библиотеки, 
представляющий сквозную, не металлизированную  площадку с диаметром под шайбу 
– 6 мм  и диаметром под винт - 2,7 мм. 
1. Вызвать Pattern Editor и командой   Pattern>Open открыть файл ShablonPRT  
2. Установить шаг сетки 0.5 мм командой Options >Grids. 
3. Создать площадку: после Options>Pad Style>Copy ввести имя TN6p0-2p7C, и нажав 

OK>TN6p0-2p7С>Modify (Simple), перейти в режим редактирования отверстия; 
4. Установить поля: Type = THRU, Width=Height=6, Hole(Diameter)=2.7, Shape=Mounting 

Hole, в поле Hole (Plated) снять флажок (нет металлизации)  и нажать Ok и Close. 
5. Ввести точку привязки: после Place> Ref Point   щелкнуть LB точке  20/20. 
6. Ввести RefDes и Type (п.5 раздел 2) в центре КП, при  снятом флажке в поле  Visible; 
7. Нарисовать пятачок (6,5 мм) для маски в слоях Top Mask и Bottom Mask этапами: 
 по команде Options >Grids  установить поля: Grid Spacing = 1.625 ( ¼ от 6,5);  X=Y=20, 

Mode = RELATIVE и щелчками LB на кнопках ADD и OK  перейти в относительную си-
стему координат с центром в точке 20 / 20; 

 по команде Options >Layers  установить текущим слой Top Mask; 
 по команде Options >Current Line установить текущей толщину линии 3.25 мм; 
 по команде Place >Arc  щелкнуть LB в точках  1,625/0  и  0/0 – 1-й пятачок готов; 
 аналогично построить пятачок в слое Bottom Mask, выключить слои Top Mask и Bot-

tom Mask и щелчком LB на кнопке REL перейти в абсолютную систему координат. 
8. Создать графику сборочного чертежа (круг 6,0 мм и осевые) этапами: 
 после Options >Layers  сделать текущим слой сборочного чертежа – Top Assy; 
 после Options >Current Line(>Grid)  установить линию 0.2 мм (сетку 0,5 мм); 
 после Place>Arc  щелкнуть LB в точках 21.5/20  и 20/20 – круг 6,0 мм построен; 
 после Place >Line щелкнуть LB в точках 20/24  и 20/16  щелкнуть RB, далее, щелкнуть 

LB в точке 24/20  и в точке 16/20 щелкнуть RB – построены осевые. 
9. Создать библиотеку Holes, для чего после Liblary > New в окне Liblary New в поле 
Имя файла ввести имя Holes и щелкнуть LB на кнопке Сохранить. 

10. Записать отверстие в библиотеку этапами: 
 после Pattern>Save As  ответить «Да» на предупреждение об отсутствии атрибута Type 

и в окне PatternSaveToLibrary, щелкнув LB на кнопке Library, установить путь к биб-
лиотеке Test   и нажать кнопку Открыть;  

 установив флажок в поле Component , ввести имя отверстия TN6p0-2p7C в поля: Pattern 
Name и Component Name и нажать кнопку OK. 

11. Покинуть редактор Pattern Editor командой   Pattern>Exit. 

    
TN6p0-2p7С ТM1p4-0p8R ТM1p4-0p8C P2p1-0p7R ТM1p9-1p3C 
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Стиль ТM1p4-0p8R 
1. Запустить Pattern Editor и командой   Pattern>Open открыть файл ShablonPRT  
2. Ввести параметры КП: после Options>Pad Style>Copy ввести ее имя ТМ1P4-0P8R, 

щелкнуть LB:  на OK>ТМ1P4-0P8R>Modify (Simple), изменить поля: Shape = Rectan-
gle, Width = Height= 1.4, Diameter = 0.8 и щелкнуть LB по кнопках OK и Close. 

3. Создать файл технологических параметров – FTP этапами: 
 после Pattern > DesignTechnologyParameters  ввести Имя файла= FTP и нажать на 

кнопки Открыть >Да – откроется окно Design Technology Parameters; 
 щелкнуть на кнопке New Group и ввести имя новой группы технологических парамет-

ров – КПиО (КП и Отверстия) – имя КПиО появится в списке;  
4. Записать параметры площадки в файл FTP, для чего: щелкнуть LB на имени  КПиО, 

кнопке UpdateFromDesign и, установив в окне Select Section Type флажок Pad Styles, 
щелкнуть LB  на кнопках OK> OK>Close. 

5. Аналогично создать в FTP стили ТM1p4–0p8C , TM1p9–1p3C и P2p1–0p7R указав: 
 для ТM1p4-0p8C –Type=Thru; Shape=Ellipse; Width= Height= 1.4, Diameter = 0.8; 
 для TM1p9-1p3C – Type=Thru; Shape=Ellipse; Width= Height= 1.9, Diameter = 1.3; 
 для P2p1-0p7R  – Type =Top; Shape= Rectangle; Width=2.1 Height= 0.7. 
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6. Разработка посадочного места DIP-14        

Разработка ПМ  DIP14  выполняется «Мастером ПМ» этапами: 
1. Перейти в редактор Pattern Editor командой  Utils> Pattern Editor.  
2. Подключить стеки КП из FTP: после Pattern>DesignTechnologyParameters щелкнуть 

LB на КПиО>CopyToDesignOK>Close. (9-2). 
3. Загрузить мастер ПМ командой: Pattern>Pattern Wizzard; 
4. Установить поля: Pattern Type = DIP,  Number Of Pads Down = 14 (общее число КП),  

Pad To Pad Spacing = 2.5 (расстояние между КП по Y), Pattern Width = 7.5 (расстояние 
между КП по X), Pad 1 Position = 1 (№ ключевой КП), Pad Style (Pad 1) = TM1p4-0p8R 
(ключевая КП),  Pattern Pad Style (Other) = TM1p4-0p8C  (обычная КП); 

5. Установить флажок Silk Screen и определить графику ПМ в слое Top Silk, установив 
поля:  Silk Line Width = 0.2 (ширина линии), Silk Rectangle Width = 6.0, Silk Rectangle 
Height = 17.5 (размеры корпуса), Notch Type = Arc (форма ключа около 1-го вывода) и, 
щелкнув LB на кнопке Finish, завершить работу «Мастера»; 

6. Переместить атрибуты Refdes и Type в центр ИМС и развернуть их на 90 градусов кла-
вишей R  (атрибут Type погасить); 

7. Сохранить ПМ в библиотеке Test под именем DIP–14 командой Pattern>SaveAs 
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7. Запись БЭ – К511ПУ2 в библиотеку       

1. В программе Library Executive после  Component > New установить путь к библиотеке 
Test и нажать кнопку  Открыть – откроется окно Component Information. 

2. Подключить к проекту ПМ DIP-14, для чего щелкнуть LB на кнопке Select Pattern и в 
окне Library Browse дважды щелкнуть LB на имени ПМ DIP-14 – это имя  будет 
отображено в верхнем правом поле окна Component Information. 

3. Изменить поля: Gate Numbering = Numeric; Component Style  = Heterogeneous (в кор-
пусе имеются символы разных типов – NOT–AND и 2AND–NOT), Refdes Prefix = DD, 
Number of Gates  =  4 (2 символа NOT–AND и 2 символа 2AND–NOT). 

4. Включить в корпус 1-й символ, щелкнув дважды LB на 1-й строке  колонки Normal 
и на имени NOT–AND (в пунктах 4 и 5 на все предупреждения отвечать «Нет»). 

5. Подключить остальные символы, щелкая LB в строках 2, 3 и 4 колонки Normal и 
выбирая соответственно имена: NOT–AND, 2AND–NOT и 2AND–NOT– табл.1. 

6. Нажать PinsView, ввести упаковку по табл. 2 и закрыть окно PinsView обычным путем. 

Таблица 1          Таблица 2 
Gate# GateEq Normal  Pad # Pin Des Gate # SymPin# Pin Name GateEq Pin Eq Elec.Typ 

1 1 NOT–AND  1 1 1 1 E 1  Input 
2 1 NOT–AND  2 2 1 2 In 1  Input 
3 2 2AND–NOT  3 3 1 3 Out 1  Output 
4 2 2AND–NOT  4 4 2 1 E 1  Input 
    5 5 2 2 In 1  Input 
    6 6 2 3 Out 1  Output 
    7 7 PWR  GND   Power 
    8 8 3 3 Out 2  Output 
    9 9 3 2 InB 2 1 Input 
    10 10 3 1 InA 2 1 Input 
    11 11 4 3 Out 2  Output 
    12 12 4 2 InB 2 1 Input 
    13 13 4 1 InA 2 1 Input 
    14 14 PWR  +5B   Power 

7. После Component > Validate система выдасть сообщение No errors found! (ошибок нет). 
8. Записать ЭРЭ в библиотеку Test : после Component >Save – откроется окно 

Component Name, в котором необходимо ввести имя K511PU2 и нажать Ok. 
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8. Разработка символа для ИМС 133LA6       

Микросхема 133ЛА6 (рис.10) содержит 2 символа 4AND–NOT «4И-НЕ» (рис.11). Ну-
мерация выводов символа указывает порядок их формирования при создании символа 
в среде редактора Symbol Editor. В корпусе ИМС 133ЛА6 символ 4AND–NOT занимает 
секции 1 и 2.  Распайка выводов секций на ножки ИМС показана на рис. 12. 

Символ 4AND-NOT создается мастером в редакторе  Symbol Editor этапами: 
1. Открыть шаблон: Symbol > Open > ShablonSYM и установить сетку чертежа 1,25 мм. 
2. Сохранить символ под именем  4AND-NOT командой Symbol > Save To File As. 
3. Загрузить окно «мастера создания символов» командой  Symbol > Symbol Wizard и 

установить следующие поля: Symbol Width = 15; Pin Spacing = 5;  Number Pin Left=4, 
Number Pin Right =1; Line Width= 0.2; Default Pin Name = InA; Default Pin Designator 
= Current Pin Number = 1; User = 5; установить флажки Pin Name и Pin Des.  

4. Изменить поля CurrentPinNumber =2, DefaultPinDesignator=2, Default Pin Name = InB. 
5. Аналогично построить выводы InC, InD и Out и щелкнуть LB на Finish – рис.  11. 
6. Щелкнуть LB и RB на выводе Out, перейти в окно Properties, где  изменить поле 

Outside Edge = Dot и нажать OK. 

 4AND-NOT 

Рис.10 Рис. 11 (Сетка = 2,5 мм) Рис. 12 
7. Записать символ в библиотеку Test под именем 4AND-NOT этапами:   
 после Symbol > Save As щелкнуть LB на кнопке Library, выбрать библиотеку Test и 

нажать кнопку Открыть; 
 в поле «Symbol» ввести имя 4AND-NOT, сбросить флажки и щелкнуть LB на OK. 
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9. Разработка ПМ PLAN –14         

1. Загрузить  редактор ПМ (Пуск > Программы > P-CAD 2002 > Pattern Editor). 
2. Подключить к проекту файл FTP (раздел 6, п.2). 
3. Загрузить  «Мастер ПМ» командой Pattern > Pattern Wizard и установить поля: Pat-

tern Type = DIP (форма ПМ),  Number Of Pads Down = 14 (общее число КП),  Pad To 
Pad Spacing = 1.25 (расстояние между КП по Y), Pattern Width = 10 (расстояние меж-
ду центрами КП по X), Pad 1 Position = 1 (№ ключевой КП), Pad Style (Pad 1) = P2p1-
0p7R,  Pattern Pad Style (Other) = P2p1-0p7R. 

4. Сформировать графику ПМ этапами: 
 установить флажок Silk Screen и поля:  Silk Line Width = 0.2 (тип линии), Silk Rectangle 

Width =5.5(ширина), Silk Rectangle Height = 10 (высота корпуса), Notch Type = None; 
 щелкнув LB на кнопке Finish, завершить работу «Мастера»; 
 переместить атрибуты Refdes и Type в центр ИМС и развернуть их на 90 градусов кла-

вишей R  (атрибут Type погасить); 
 изменить графику корпуса ИМС около первого контакта согласно рис.12; 
5. Сохранить ПМ в библиотеке Test под именем Plan–14. 
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10. Запись БЭ - 133LA6 в библиотеку       

1. Запустить библиотекарь: Utils>Library Executive и после  Component > New установить 
путь к библиотеке Test и нажать Открыть – откроется окно Component Information. 

2. Подключить к проекту ПМ PLAN-14, для чегощелкнуть LB на кнопке Select Pattern 
и в окне Library Browse дважды щелкнуть LB на имени ПМ PLAN-14– оно  будет 
отображено в верхнем правом поле. 

3. Установить: Gate Numbering=Numeric; RefdesPrefix=DD, ComponentStyle = Homoge-
neous (символы в корпусе идентичны),  Number of Gates = 2 (2 символа 4AND-NOT) 

4. Включить в корпус 1-й символ, щелкнув дважды LB на 1-й строке  колонки Normal 
и на имени 4AND-NOT (на сообщение системы ответить «Нет»). Аналогично вклю-
чить в корпус 2-й символ 4AND-NOT– получена табл. 3. 

5. Нажать кнопку PinsView , ввести упаковку по табл.4, и закрыть окно PinsView. 
6. Записать созданный элемент 133LA6 в библиотеку, выполнив пп 78 раздела 7. 
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11. Разработка БЭ  диод  KD403A        

Распайка выводов символа DIOD (рис.13) на ножки ПМ KD403A показаны на рис.14.  
Символ DIOD создается в редакторе символов  Symbol Editor в следующем порядке  
1. Открыть шаблон: Symbol > Open > ShablonSYM и установить сетку чертежа 1,25 мм. 
2. Сохранить символ под новым именем:  DIOD командой Symbol > Save To File As. 
3. Загрузить окно «Мастер символов» командой  Symbol > Symbol Wizard и установить 

следующие поля: Symbol Width = 7.5; Pin Spacing = 5;  Number Pin Left=Number Pin 
Right =1; Line Width= 0.2; Default Pin Name = +; Default Pin Designator = Current Pin 
Number = 1; User = 5; флажки Pin Name и Pin Des – сбросить.  

Таблица 3         Таблица 4 
Gate# GateEq Normal  Pad # Pin Des Gate # SymPin# Pin Name GateEq Pin Eq Elec.Typ 

1 1 4AND–NOT  1 1 1 1 InA 1 1 Input 
2 1 4AND–NOT  2 2 1 2 InB 1 1 Input 
    3 3       
    4 4 1 3 InC 1 1 Input 
    5 5 1 4 InD 1 1 Input 
    6 6 1 5 Out 1  Output 
    7 7 PWR  GND   Power 
    8 8 2 5 Out 1  Output 
    9 9 2 1 InA 1 1 Input 
    10 10 2 2 InB 1 1 Input 
    11 11       
    12 12 2 3 InC 1 1 Input 
    13 13 2 4 InD 1 1 Input 
    14 14 PWR  +5B   Power 

 

 
Рис. 13 (Сетка = 2,5 мм) Рис. 14 Рис. 15 

4. Ввести: Current Pin Number = 2,  Default Pin Designator =2  и Default Pin Name = – . 
5. Щелкнуть LB на Finish и изменить графику символа в соответствии с рис.13 (рис.15). 
6. Записать символ в библиотеку Test под именем DIOD , для чего: после Symbol > 

Save As щелкнуть LB на кнопке Library, выбрать библиотеку Test , нажать кнопку 
Открыть и в поле Symbol ввести имя символа DIOD, сбросить флажки во всех по-
лях  и щелкнуть LB на кнопке OK. 

Посадочное место диода KD403A создается в редакторе Pattern Editor этапами: 
1. Подключить к проекту файл FTP (раздел 6, п.2). 
2. Загрузить  Мастер ПМ : Pattern > Pattern Wizard и установить поля: Pattern Type = 

DIP,  Number Of Pads Down = 2 ,  Pad To Pad Spacing = 3.75, Pattern Width = 15, Pad 1 
Position = 1, Pad Style (Pad 1) = TM1p4-0p8C,  Pattern Pad Style (Other) = TM1p4-0p8C. 

3. Для определения графики ПМ установить флажок в поле  Silk Screen и поля: Silk Line 
Width = 0.2, Silk Rectangle Width = 7, Silk Rectangle Height = 4, Notch Type = None. 
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4. Щелкнув LB на кнопке Finish, завершить работу «Мастера» - (рис.16). 
5. Установить сетку 0,5 мм и при нажатом CTRL щелкнуть LB в центре каждой  вер-

тикальной линии УГО , после чего нажать клавишу Delete – линии будут удалены. 
6. Нарисовать дуги согласно рис. 17, для чего: в слое TopSilk после Place > Arc  нажать 

LB в точке A (рис.17) и отпустить LB – в точке C (рис.18). Аналогично построить 
правую дугу, нажав LB в точке D (рис.17) и отпустиь– в точке B (рис.17). 

7. Переместить атрибуты Refdes и Type в центр ПМ (атрибут Type погасить) и запи-
сать ПМ в библиотеку Test под именем КD403A командой Pattern > Save As при 
сброшенном флажке Create Component. 

 
Рис. 16  (Сетка = 1,0 мм) Рис. 17  (Сетка = 1,0 мм) Рис. 18  (Сетка = 1,0 мм) 

Запись БЭ диода KD403A в библиотеку выполняется в программе Library Executive. 
1. После Component>New указать путь к библиотеке Test и нажать кнопку Открыть. 
2. Подключить к проекту ПМ диода, для чего щелкнуть LB на кнопке Select Pattern и в 

окне Library Browse дважды щелкнуть LB на имени ПМ диода KD403A – оно  будет 
отображено в верхнем правом поле. 

3. Изменить поля: Gate Numbering= Numeric;  Number of Gates = 1; Refdes Prefix=VD. 
4. Подключить символ DIOD, щелкнув дважды LB в 1-й строке колонки Normal и на 

имени  DIOD  (табл. 5). 
5. Нажать кнопку PinsView, ввести упаковку по табл.6 и закрыть окно PinsView.  
6. Записать созданный элемент KD403A в библиотеку, выполнив п 78 раздела 7. 

       Таблица 5                    Таблица 6 
Gate# GateEq Normal  Pad # Pin Des Gate # SymPin# Pin Name GateEq Pin Eq Elec.Typ 

1 1 DIOD  1 1 1 1 + 1  Unknown 

    2 2 1 2 – 1  Unknown 
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12. Разработка БЭ - транзистор KT3102G       
Транзистор KT3102G содержит 1 символ NPN (рис.19). в корпусе KT3102G (рис.  20) 
Символ NPN создается в редакторе символов  Symbol Editor в следующем порядке  
1. Открыть шаблон ShablonSYM и сохранить его как файл (As File) под именем:  NPN. 
2. Выбрав в строке статуса шаг сетки 0,5 мм, построить УГО символа этапами:  
 после Place > ARC, переместить курсор в точку  8,5/15 и щелкнуть LB, далее – в точку 

15/15 и щелкнуть LB – построена окружность радиуса 6,5 мм;   
 нарисовать базу: после Place>Line щелкнуть LB в точках  12/12 и 12/18, щелкнуть RB, 

щелкнуть LB в точках  8,5/15  и 12/15 щелкнуть RB – введена база;   
 нарисовать  коллектор и эмиттер: после Place >Line щелкнуть LB в точках 12/16,5 и 

18.75/20  щелкнуть RB;  щелкнуть LB в точках 12/13,5  и 17.75/10,5  – щелкнуть RB; 
 нарисовать  стрелку эмиттера: ввести сетку 0.25 мм, и после Place>Polygon  щелкнуть 

LB в точках 17,75/11 , 17,25/10,25 ,  18,75/10   щелкнуть RB (рис.  21);   
 после Option > Display > Polygon установить цвет заливки полигона = цвету линий. 
3. Сформировать выводы символа NPN в сетке 1.25 мм этапами: 

 
NPN   

Рис.19 Рис.20 Рис.21 Рис.22 Рис.23 (Сетка = 0,5 мм) 

 после Place>Pin установить: Default PinName = B, User = 2,5 мм,   Default Pin Des = 1, 
поля Pin Name, Pin Des, Increment Pin Name  и Increment Pin Des сбросить; 

 щелкнуть LB  на кнопке Ok  и в точке  8,75/15 , щелкнуть RB –   рис.  21 (база); 
 щелчком LB перейти в окно Place Pin, изменить поля: Default Pin Name = K, Default Pin 

Des = 2, щелкнуть LB  на кнопке Ok, нажать LB в точке  8,75/20  и, не отпуская LB, 3 
раза подряд нажать клавишу «R», – щелкнуть RB (рис.  22 – коллектор); 

 щелчком LB перейти в окно Place Pin, и изменить поля: Default Pin Name = E, Default 
Pin Des = 3, далее щелкнуть LB  на кнопке Ok, нажать LB в точке  8,75/10  и, не отпус-
кая LB, нажать клавишу «R», - щелкнуть RB – рис.  19 (без атрибутов). 

4. В точки:   6,25/15 ,   16,25/25 и 16,25/5   ввести Ref Point, RefDes и  Type (п. 5 раздел 2) 
5. Ввести точку привязки элемента:  после Place > Ref Point щелкнуть LB в точке 6,25/15. 
6. Записать символ в библиотеку Test под именем  NPN и выйти из редактора. 
ПМ транзистора KT3102G создается в редакторе Pattern Editor этапами:  
1. Подключить к проекту файл FTP (раздел 6, п.2) 
2. Загрузить  «Мастер ПМ» командой Pattern > Pattern Wizard и установить поля: Pat-

tern Type = DIP,  Number Of Pads Down = 4 ,  Pad To Pad Spacing = 2.5, Pattern Width 
= 5, Pad 1 Position = 1, Pad Style (Pad 1) = TM1p9-1p3C , Pattern Pad Style (Other) = 
TM1p9-1p3C и установить флажок в поле  Silk Screen  

3. Ввести: Silk Line Width=0.2, Silk Rectangle Width=8, Silk Rectangle Height=3.5, Notch Type=None.  
4. Щелкнув LB на Finish, - перейти в обычный режим редактирования ПМ. 
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5. Удалить правую верхнюю площадку и переместить на ее место – нижнюю правую. 
Левую нижнюю КП переместить по той же горизонтали – в центр ПМ (рис.  23). 

6. Переместить атрибуты Refdes и Type в центр ПМ (атрибут Type погасить) и запи-
сать ПМ в библиотеку Test под именем KT3102G командой Pattern > Save As при 
сброшенном флажке Create Component. 

Запись БЭ KT3102G в библиотеку выполняется в программе Library Executive. 
1. После Component>New указать путь к библиотеке Test и нажать кнопку Открыть. 
2. Подключить к проекту ПМ транзистора, для чего щелкнуть LB на кнопке Select Pat-

tern и в окне Library Browse дважды щелкнуть LB на имени ПМ транзистора  
KT3102G – оно  будет отображено в верхнем правом поле. 

3. Изменить поля: Gate Numbering= Numeric;  Number of Gates = 1; Refdes Prefix=VT. 
4. Подключить символ NPN, щелкнув дважды LB в 1-й строке колонки Normal и в от-

крывшемся оглавлении библиотеки Test – на имени  NPN  (табл. 7). 
5. Нажать кнопку PinsView и ввести упаковочную информацию согласно табл.8.  
6. Записать компонент KT3102G в библиотеку, выполнив пункты 78 раздела 7. 

Таблица 7            Таблица 8 
Gate# GateEq Normal  Pad # Pin Des Gate # SymPin# Pin Name GateEq Pin Eq Elec.Typ 

1 1 NPN  1 1 1 1 B 1  Unknown 
    2 2 1 2 K 1  Unknown 
    3 3 1 3 E 1  Unknown 
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13. Разработка БЭ - клемма GND        

1. В редакторе Symbol Editor открыть файл ShablonSYM и установить сетку = 1,25 мм. 
2. Командой Symbol>Save To File As сохранить символ под  именем GND. 
3. После  Symbol > Symbol Wizard и установить следующие поля: Symbol Width = 0; Pin 

Spacing = 5; Number Pin Left=1; Number Pin Right=0; Line Width = 1; Default Pin Name 
– не заполнять; Default Pin Designator = Current Pin Number = 1; User = 5; флажки Pin 
Name и Pin Des – сбросить, после чего щелкнуть LB на кнопке Finish.  

4. Удалить атрибут Type,  повернуть атрибут RefDes на 90 градусов переместить его в 
центр символа и погасить (рис. 24). 

 
GND  

Рис. 24 

5. После Symbol >Save As записать символ в библиотеку � этапами: 

 в поле «Library» – установить путь к библиотеке � 

 в поле Symbol ввести имя GND, в полях Match  и CreateComponent  уста-
новить флажки, а в поле Component ввести имя GND и нажать Ok; 

 на вопросы системы ввести «Да» – откроется окно Save Component As; 
 в окне Component Type отметить строку Power и щелкнуть LB на OK; 
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14.  Разработка БЭ - разъем ON-KS-10       

Разъем ON-KS-10 (рис.25) содержит 7 символов ON-KS  (рис. 26). 
Символ ON-KS создается в редакторе символов  Symbol Editor в следующем порядке  
1. В редакторе Symbol Editor открыть файл ShablonSYM и установить сетку = 1,25 мм. 
2. Командой Symbol>Save To File As сохранить символ под  именем ON-KS. 
3. После  Symbol>Symbol Wizard установить поля: Symbol Width = 32; Pin Spacing = 5; 

Number Pin Left=1; Number Pin Right=0; Line Width = 0.2; Default Pin Name – не за-
полнять; Default Pin Designator = Current Pin Number = 1; User = 5; флажок Pin Name 
сбросить, а флажок Pin Des – установить и щелкнуть LB на Finish.  

4. Удалить атрибут Type,  атрибут RefDes переместить в центр символа и погасить. 
5. Установить номер вывода, как показано на рис. 26, и провести вертикальную линию. 
6. Командой Symbol > Save As записать созданный символ в библиотеку Test под име-

нем ON-KS,  сбросив флажок Create Component. 

 

Рис. 25 (Сетка =1,25 мм) Рис. 26 (Сетка =1,25 мм) 

Посадочное место соединителя ON-KS-10 создается в редакторе Pattern Editor  
1. Подключить к проекту файл FTP (раздел 6, п.2). 
2. После Pattern > Pattern Wizard установить сетку = 1.25 мм и изменить поля: PadTo-

PadSpacing =2.5 , Number Of Pads Down=14, Pattern Width=0, Pad 1 Position = 1, Pad 
Style (Pad 1) = TM1p4-0p8C,  Pattern Pad Style (Other) = TM1p4-0p8C 

3. Построить графику ПМ этапами: 
 установить флажок Silk Screen и ввести:  Silk Line Width = 0.2 (ширина линии), Silk Rec-

tangle Width = 5, Silk Rectangle Height = 20 (габариты), Notch Type = None; 
 щелкнув LB на кнопке Finish, завершить работу «Мастера»; 
 переместить атрибут Refdes в центр ИМС и клавишей R развернуть его на 90о. 
4. Удалить парные площадки с 8 по 14, выбирая их в окне выбора (после щелчка LB 

на каждой площадке) и нажимая клавишу Delete. 
5. Сохранить ПМ в библиотеке Test под именем ON-KS-10. 

Запись БЭ разъема ON-KS-10 в библиотеку программой Library Executive: 
1. После Component>New указать путь к библиотеке Test и нажать кнопку Открыть. 
2. Подключить ПМ ON-KS-10 – оно  будет отображено в верхнем правом поле. 
3. Изменить поля: Gate Numbering= Numeric;  Number of Gates = 7; Refdes Prefix=X. 
4. Подключить символ ON-KS, щелкнув дважды LB в 1-й строке колонки Normal и в 

открывшемся оглавлении библиотеки Test – на имени ON-KS (табл. 9). 
5. Нажать кнопку PinsView, ввести упаковку по табл.10 и закрыть окно PinsView 
6. Записать созданный элемент ON-KS-10 в библиотеку (п 78 раздел 7). 

Таблица 9        Таблица 10 
Gate# GateEq Normal  Pad # Pin Des Gate # SymPin# Pin Name GateEq Pin Eq Elec.Typ 

1 1 ON-KS  1 1 1 1 1 1  Unknown
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2 1 ON-KS  2 2 2 1 1 1  Unknown
3 1 ON-KS  3 3 3 1 1 1  Unknown
4 1 ON-KS  4 4 4 1 1 1  Unknown
5 1 ON-KS  5 5 5 1 1 1  Unknown
6 1 ON-KS  6 6 6 1 1 1  Unknown
7 1 ON-KS  7 7 7 1 1 1  Unknown
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15. Разработка БЭ - РЕЗИСТОР C2-33        

Один символ R (рис.27)  размещается в корпусе C2-33 (рис.28) размером 6 x 2,2 мм.  
Символ R создается мастером в редакторе символов  Symbol Editor этапами:  

  
R (10  4 мм)   Ref Point  (10/10) мм 

 
С2-33 (6  2,2 мм) 

Primary 

 
С2-33 

Secondary 

Рис. 27  (Сетка = 1,25 мм) Рис. 28 (Сетка = 1 мм) 
1. В редакторе Symbol Editor открыть файл ShablonSYM и установить сетку = 1,25 мм. 
2. Командой Symbol>Save To File As сохранить символ под  именем R. 
3. После  Symbol>Symbol Wizard ввести: Symbol Width=10; PinSpacing=2; NumberPin Left 

=1; NumberPinRight=1; Line Width=0.2; Default PinName–не заполнять; Default Pin 
Designator = Current Pin Number = 1; User = 5; флажки Pin Name и Pin Des – сбросить.  

4. Установить далее поле  Current Pin Number = 2 и изменить поле Default Pin Designa-
tor =2; User = 5; флажок PinDes – сбросить и щелкнуть LB на кнопке Finish. 

5. Записать символ в библ. Test как R, сбросив флажок Create Component. 

ПМ резистора С2-33   создадим в Pattern Editor в двух вариантах установки на ПП. 
1. Подключить к проекту файл FTP (раздел 6, п.2). 
2. Ввести имя 2-го варианта ПМ резистора (рис.28 справа), для чего после Pattern > 

Add Pattern Graphic установить поле Name = Secondary и нажать ADD и Close. 
3. После Pattern>Pattern Wizard установить: Pattern Type= DIP,  Number Of Pads Down = 2,  

Pad To Pad Spacing = 2,5, Pattern Width = 10  Pad 1 Position = 1, Pad Style (Pad 1) = 
TM1p4-0p8C,  Pattern Pad Style (Other) = TM1p4-0p8C ;  Silk Line Width = 0.2, Silk Rectan-
gle Width = 6, Silk Rectangle Height = 2.2, Notch Type = None и щелкнуть LB на Finish. 

4. Переместить атрибут Refdes в центр ПМ  (атрибут Type погасить). 
5. Щелкнуть LB на кнопке Next Pattern Graphic панели Command Tools Bar редактора и 

на новом листе повторить пункт 3, изменив поле: Pattern Width = 2,5. 
6. Удалить прямоугольник  на чертеже и погасить атрибут Type. 
7. Сохранить ПМ в библ. Test под именем С2-33, сбросив флажок Creat Component. 

Запись БЭ резистора С2-33 в библиотеку Test в программе Library Executive. 
1. После Component>New указать путь к библиотеке Test и нажать кнопку Открыть. 
2. Подключить к проекту ПМ резистора, для чего щелкнуть LB на кнопке Select Pat-

tern и в окне Library Browse дважды щелкнуть LB на имени С2-33. 
3. Установить: GateNumbering=Numeric;  NumberOfGates=1; RefdesPrefix=R и подключить 

символ R, щелкнув 2 раза LB в 1-й строке колонки Normal и на имени  R  (табл. 11). 
4. Нажать кнопку PinsView, ввести упаковку по табл.12, и закрыть окно PinsView.  
5. Записать созданный элемент С2-33 в библиотеку,  (п 78 раздел 7). 

Таблица 11          Таблица 12 
Gate# GateEq Normal  Pad # Pin Des Gate # SymPin# Pin Name GateEq Pin Eq Elec.Typ 

1 1 R  1 1 1 1 1 1  Unknown 
    2 2 1 2 2 1  Unknown 
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16. Разработка БЭ – КАТУШКА D1-1,2-1       

Символ L (рис.29) содержится в  корпусе  катушки D1-1,2-1 (рис.30) размером 14  4 мм.  
Символ L создается в редакторе символов  Symbol Editor в следующем порядке  
1. В редакторе Symbol Editor открыть файл ShablonSYM и установить сетку = 1,25 мм. 

 
L (Радиус витка =1 мм)  Ref 

Point  (7,5/15) мм 

 

D1-1.2-1 (14  4 мм) 

Pattern Type = DIP              Pattern Width = 17,5
NumberOf Pads Down = 2  Pad To Pad Spacing = 2,5 
Pad 1 Position = 1   Pad Style (Pad 1) = TM1p4-0p8C 
Pattern Pad Style (Other) = TM1p4-0p8C 
Silk Line Width = 0.2, Silk Rectangle Width = 14,  
Silk Rectangle Height = 4, Notch Type = None 

Рис. 29  (Сетка = 1,25 ) Рис. 30 (Сетка = 1,25 мм) 

2. Командой Symbol>Save To File As сохранить символ под  именем L. 
3. После  Symbol > Symbol Wizard ввести: Symbol Width = 8; Pin Spacing = 2; Number Pin 

Left=Number Pin Right=1; Line Width = 0.2; Default Pin Name – не заполнять; Default Pin 
Designator = Current Pin Number = 1; User = 3.5; флажки Pin Name и Pin Des – сбросить.  

4. Установить далее поле  Current Pin Number = 2 и ввести: Default Pin Designator =2; 
сбросить флажок PinDes и щелкнуть LB на кнопке Finish. 

5. Удалить все линии корпуса и, установив сетку = 1 мм, нарисовать 4 витка катушки 
командой Place>Arc. 

6. Записать символ в библиотеку  Test как L, сбросив флажок Create Component. 

Посадочное место катушки индуктивности D1-1,2-1 создается в редакторе Pattern Editor. 
1. Подключить к проекту файл FTP (раздел 6, п.2). 
2. После Pattern > Pattern Wizard, ввести поля согласно рис. 30 и щелкнуть LB на Finish 
3. Переместить атрибут Refdes в центр ПМ  (атрибут Type погасить); 
4. Сохранить ПМ в библиотеке Test как D1-1,2-1, без флажка Creat Component. 

Запись БЭ катушки D1-1,2-1 в библиотеку в программе Library Executive. 
1. После Component>New указать путь к библиотеке Test и нажать кнопку Открыть. 
2. Подключить к проекту ПМ катушки, для чего щелкнуть LB на кнопке Select Pattern 

и в окне Library Browse дважды щелкнуть LB на имени ПМ катушки D1-1,2-1. 
3. Изменить поля: Gate Numbering= Numeric;  Number of Gates = 1; Refdes Prefix=L. 
4. Подключить  к проекту символ L (табл.13). 
5. Нажать кнопку PinsView, ввести упаковку по табл.14 и закрыть окно PinsView 
6. Записать элемент D1-1,2-1 в библиотеку (п 78 раздела 7). 

Таблица 13          Таблица 14 
Gate# GateEq Normal  Pad # Pin Des Gate # SymPin# Pin Name GateEq Pin Eq Elec.Typ 

1 1 L  1 1 1 1 1 1  Unknown 
    2 2 1 2 2 1  Unknown 
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17. Конденсаторы  K10-43A и K73-15         

Символ C (рис.31) содержится в корпусе K10-43A размером 11  5 мм (рис.32).  
Символ C создается мастером в редакторе Symbol Editor в следующем порядке  
1. Открыть шаблон: Symbol>Open>ShablonSym и установить сетку чертежа 1,25 мм. 
2. После Symbol>Save>To File As сохранить символ в папке проекта под  именем R. 
3. После  Symbol > Symbol Wizard установить поля согласно рисунку 31; 
4. Ввести Default Pin Designator =1 и нажать клавишу Enter; установить далее поле  

Current Pin Number = 2, ввести Default Pin Designator =2, нажать клавишу Enter, 
флажок PinDes – сбросить и щелкнуть LB на кнопке Finish.  

5. Удалить верхнюю и нижнюю линии на полученном рисунке, щелкнув LB на каж-
дой из них (при нажатой клавише Ctrl) и нажав клавишу Delete.  

6. Записать символ в библиотеку Test под именем С, без флажка Create Component. 
Symbol Width = 1.25;    Pin Spacing = 4 
NumberPin Left=1;  Number Pin Right=1 
Line Width = 0.8;      User = 5,75 
Default Pin Name – не заполнять 
Pin Name и Pin Des – сбросить 

Pattern Type = DIP              Pattern Width = 7,5
NumberOf Pads Down = 2  Pad To Pad Spacing = 2,5 
Pad 1 Position = 1   Pad Style (Pad 1) = TM1p4-0p8C 
Pattern Pad Style (Other) = TM1p4-0p8C 
Silk Line Width = 0.2, Silk Rectangle Width = 10,  
Silk Rectangle Height = 5, Notch Type = None 

Рис. 31  (Сетка = 1,25 мм) Рис. 32 (Сетка = 1,25 мм) 

ПМ конденсатора K10-43A создается мастером  в редакторе Pattern Editor. 
1. После Pattern > Pattern Wizard, установить поля по рис. 32 и щелкнуть LB на Finish 
2. Переместить атрибут Refdes в центр ПМ  (атрибут Type погасить); 
3. Сохранить ПМ в библиотеке Test как K10-43A, без флажка Creat Component. 

Запись БЭ K10-43A в библиотеку выполним в программе Library Executive. 
1. После Component>New указать путь к библиотеке Test и нажать кнопку Открыть. 
2. Подключить ПМ, щелкнув LB на кнопке Select Pattern и на имени ПМ K10-43A. 
3. Изменить поля: Gate Numbering = Numeric; Number of Gates = 1; Refdes Prefix=С; 
4. Подключить  к проекту символ С (табл. 15); 

Таблица 15          Таблица 16 
Gate# GateEq Normal  Pad # Pin Des Gate # SymPin# Pin Name GateEq Pin Eq Elec.Typ 

1 1 С  1 1 1 1 1 1  Unknown 
    2 2 1 2 2 1  Unknown 

5. Нажать кнопку PinView ввести упаковку по табл.16  и закрыть окно PinView.  
6. Записать созданный элемент K10-43A в библиотеку (п 78 раздела 7). 

Символ CE (рис.33) содержится в корпусе K73-15 (рис.34) размером 16,5  6 мм и 
создается на основе символа C (знак «+» можно ввести командой Place>Text). 

 
 

Pattern Type = DIP                   Pattern Width = 22,5
NumberOf Pads Down = 2        Pad To Pad Spacing = 3 
Pad 1 Position = 1    Pad Style (Pad 1) = TM1p4-0p8C 
Pattern Pad Style (Other)   =   TM1p4-0p8C 
Silk Line Width = 0.2 Silk Rectangle Width = 16,5,  
Silk Rectangle Height = 6 Notch Type = None 

Рис. 33  Рис. 34 (Сетка = 1,25 мм) 
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ПМ конденсатора K73-15 создается мастером  в редакторе Pattern Editor. 
1. Подключить к проекту файл FTP (раздел 6, п.2)  
2. После Pattern>PatternWizard, установить поля по рис.34 и щелкнуть LB на Finish 
3. Переместить атрибут Refdes в центр ПМ  (атрибут Type погасить); 
4. Сохранить ПМ в библиотеке Test под именем K73-15, без флажка Creat Component. 
Запись БЭ K73-15 в библиотеку аналогична записи БЭ K10-43A,  но вместо K10-43A 
подключается ПМ K73-15, а вместо символа C подключается символ CE  и в  каче-
стве имени при записи элемента в библиотеку используется имя  K73-15. 
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18.  Разработка   форматки  для Э3         

Шаг 1. Формирование линий границ чертежа и штампа. 
1. В редакторе Schematic после Options>Configure>mm установить размер листа 440  320. 
2. После Place > Line  создать рамку листа, введя с клавиатуры: j10 Tab 10 Enter j430 Tab 

10 Enter j430 Tab 307 Enter j10 Tab 307 Enter  j10 Tab 10 Enter  Esc. 
3. После Place > Line  создать рамку чертежа, введя с клавиатуры: j30 Tab 15 Enter j425  

Tab 15 Enter j425 Tab 302 Enter j30 Tab 302 Enter j30 Tab 15 Enter Esc; 
4. Расставить 12 опорных точек: по команде Place > RefPoint щелкнуть LB в точке 240/15 

– установлена точка  № 12 (рис.  35). 

Рис.35 
5. После Edit > Select щелкнуть LB и RB в точке 240/15  и в окне Edit Copy Matrix устано-

вить поля: Number of Columns = 1 (Число колонок), Columns Spacing = 0 (Зазор между 
колонками), Number of Rows = 12 (Число рядов), Row Spacing = 5 (Зазор между рядами) 
и щелкнуть Ok (короче - установить:  1/0/12/5) – точки  №№112; 

6. Аналогично в точке №1 установить: 2/7/1/0 (получена точка №13). В точке № 13 – 
2/10/1/0  (№14). В точке № 14 – 2/23/1/0 (№15). В точке №15–  2/15/1/0 (№16).  В 
точке №16 –  2/10/1/0 (№17). В точке №12 – 2/135/2/40 (№№1819); в точке №12: 
2/185/2/55 (№№2021); в точке №18 установить: 2/15/2/-25 (№№2224); наконец, в 
точке №22 установить: 2/17/2/-20 (№№2526). 

7. Командой Place > Line  создать линии штампа, и удалить опорные точки этапами: 
8. Командой Options>BlockSelection>ClearAll >Ref Point >Ok сделать «видимыми» для 

команды Select только точки RefPoin, 
9. После Edit > Select щелкнуть LB в точке 230/80 , затем – в точке 430/10 и нажать кла-

вишу Delete – все опорные точки будут удалены; 
10. После Options>BlockSelection>SelectAll>Ok восстановить начальное состояние окна. 
11. После File >DXFOut >Sheet1>Dfaft>mm, щелкнуть LB на кнопке DXF Filename и задав имя: 

A3, сохранить форматку на диске в формате DXF командой  Сохранить > OK  
Шаг 2.  Формирование шрифтов  (п.6 раздел 1). 
Шаг 3.  Нанесение надписей в поле штампа (рис.35) выполнить  шрифтом 2.5 
Шаг 3.  Оформление реквизитов проекта. 
Примером реквизита может служить заштрихованное поле (рис.34) справа от слова 
Проверил. Если присвоить этому полю имя ФИО проверил  и  записать сюда ФИО 
(Иванов П.И.), то «ФИО проверил» будет представлять имя реквизита, а Иванов П.И –  
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сам реквизит. Собственно реквизиты, отличающиеся от проекта к проекту, вводятся 
при ведении проекта. При создании же форматки в штамп вводятся только имена и 
форматы реквизитов в следующем порядке: 
1. После File > Design Inf выбрать закладку Fields и щелкнуть LB на ADD. 
2. В поле Name ввести имя реквизита – ФИО проверил, щелкнуть LB на Ok – имя рекви-

зита будет добавлено в список,   после чего – щелкнуть LB на кнопке Close. 
3. Ввести параметры переменной части реквизита (пустышки)этапами: 
 по команде Option > Grid выбрать шаг сетки 1.0 мм 
 по команде Place > Field  дважды щелкнуть LB на имени ФИО проверил; 
 щелкнуть LB в точке  259/37  – появится имя реквизита в виде {ФИО проверил}; 
 по команде Edit > Select щелкнуть LB и затем RB в центре надписи {ФИО проверил} и 

в щелкнуть LB на строке Properties – откроется окно Field Properties; 
 в поле Text Style установить значение 3.5,  в поле Justification щелкнуть LB на левом 

среднем флажке и на кнопке Ok. 
 аналогично ввести имя {Разработал}  в точку 259/42, {Наименование}  в точку 318/46, 

имя {Т. контроль}  в точку 259/32, имя {Н. контроль}  в точку 259/22, имя имя {ФИО 
утвердил}  в точку 258/17, имя {Обозначение}  в точку 318/62. 

4. Записать форматку на диск в папку C:\Programm Files\PCAD 2002 \Titles командой 
File > Save As под именем A3–R и переименовать файл A3–R в файл A3–R.TTL 
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19. Разработка принципиальной электрической схемы     

Шаг 1.  Разработка шаблона ПЭС: 
1. Командой Пуск > Программы > PCAD 2002 > Schematic запустить редактор схемы и 

после  Option > Configure  установить поля: Units = mm;  Width= 440, Height= 320 и 
флажки в полях Orthogonal Modes и  Auto Save. 

2. Принять число архивных копий Number of Backup Files = 2 и щелкнуть LB на Ok. 
3. Установить сетки: 10.0, 0,5 и  1.25 мм и ширину линий = 0,6, 0.4, 0.2 мм. 
4. Подключить форматку A3–RUS.TTL этапами: 
7. после  Options >Configure щелкнуть LB на Edit Title Sheets… и в поле Sheets окна Options 

Sheets щелкнуть LB на строке  Sheet1 – активизируется кнопка  Custom; 
8. подключить форматку к шаблону: после Custom>Select  в окне Open Title Block устано-

вить путь к файлу A3-rus.ttl: c:\Programm Files\PCAD-2002\Titles\ A3-RUS.TTL и после-
довательно щелкнуть LB на кнопках Открыть>Modify>Close>Ok. 

5. Записать шаблон на диск: File > Save как ShablonSCH 

 

Шаг 2.  Разработка ПЭС. 
1. В редакторе Schematic открыть файл  ShablonSCH и ввести необходимые реквизиты. 

Например, для ввода реквизита {Наименование}: после File > Design Info > Fields 
щелкнув дважды LB в столбце Name на слове Наименование, перейти в окно Field  
Properties , в поле Value ввести имя схемы (Test) и нажать OK и Close.  

2. Установить курсор в виде прямого креста командой Options >Display >Miscellane-
ous >Small Cross или клавишей «X» и шаг сетки = 5 мм. 

3. Подключить библиотеку Test: после Library > Setup > Add  в окне Library Setup List-
ing указать путь к библиотеке Test и нажать Открыть и OK. 

4. Установить ЭРЭ на схему по табл.17. Например, C1  устанавливается этапами:  
 по команде Place >Part дважды щелкнуть LB на строке К10-43А, нажать LB в точке  

230 /155, щелкнуть клавишей R, отпустить LB и щелкнуть RB, – конденсатор  устано-
вится на схему вертикально с присвоением ему  обозначения С1; 

 ввести номинал емкости (в виде 4700p): после Edit>Select щелкнуть LB и, затем, RB в 
центре C1; щелкнуть LB на строке Properties и в  окне Part Properties выбрать закладку 
Symbol и вместо {Value} ввести 4700p;  

 погасить номер 1-го контакта С1: выбрать закладку Symbol Pins, щелкнуть LB на 1-й 
строке поля Pins, убрать флажок в поле Display окна  Pin Designator, щелкнуть LB и 
Apply, (аналогично погасить номер для 2-го контакта С1 и нажать OK) 

 (для символов разъема вместо поля Pin Designator погасить поле Pin Name) 
5. Сохранить файл на диске: после File >Save >Save As в окне Save As  установить:  
Тип файла = Binary Files,  Имя файла =  Test, и  щелкнуть LB на кнопке Сохранить. 

6. Построить электрическую шину командой Place > Bus этапами:  
 щелкнуть LB в точках: 120/170 , 120/260 , 175/260 , 175/150 , – щелкнуть RB;  
 аналогично построить шину, проходящую по точкам: 220 /145 , 220 /260 , 175 /260  
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Таблица 17 
ЭРЭ RefDes Номинал Координаты базовой 

точки Наименование Type на Э3 в проекте 
 Конденсатор  К10 – 43А С1 4700 пФ 4700p R 230/155
   K73 –15  С2 1,5 мкФ160В 1.5*160 140 /175
 Диод  KD403A VD1 5,5 Ом 5,5 R 140/150
 Трапзистор  KT3102G VT1 5,5 Ом 5,5 155/175
 Резистор  C2-33 R1 5,5 Ом 5,5 R 130/155

  R2 500 Ом 500 R 140/180
  R3 4,7 кОм 4,7k 135/210

 Дроссель D1–1p2–1 L1 1 мкГн 1 230/222,5
Микросхема K511PU2 DD1.1 (И–НЕ) (NOT–AND) 130/230
   DD1.2 (И–НЕ) (NOT–AND) 185/145
   DD1.3 (2И–НЕ) (2AND–NOT) 185/215
   DD1.4 (2И–НЕ) (2AND–NOT) 185/185
Микросхема 133LA6 DD2.1 (4И–НЕ) (4AND–NOT) 185/250
   DD2.2 (4И–НЕ) (4AND–NOT) 230/255
 Клемма «Земля»  Gnd PWR1 130/145
  PWR2 167,5/145
  PWR3 230/145
 Разъем  ON-KS-10 X1-1 (+5B) 250/210
  ON-KS-10 X1-2 (A5) 250/205
  ON-KS-10 X1-3 (OUT) 250/200
  ON-KS-10 X1-4 (INP) 250/195
  ON-KS-10 X1-5 (STROB) 250/190
  ON-KS-10 X1-6 (EXIT) 250/185
  ON-KS-10 X1-7 (GND) 250/180

  
Рис. 36 

7. Построить цепи схемы согласно рис. 36.  Например, ввод цепи A1 выполняется этапами: 
 ввести ширину проводников = 0,1 мм (Option >Current Wire) и после Place >Wire щелк-

нуть LB в точках: 215/155 , 215 /170 , 230 /170 , 230/167,5  – щелкнуть RB; 



 27

 остальные участки цепи A1 подключить через шину, щелкнув LB в точке 215 /155  да-
лее – на шине в точке 220/155 – щелкнуть RB (аналогично подключить к шине левые 
контакты символов L1 и R3);  

 установить коннекторы подключения цепи к шине: после  Place > Port , щелкнуть LB в 
центре экрана, – в окне Place Port установить: Net Name = A1, Pin Count = One Pin, Pin 
Length = Short, Pin Orientation = Vertical, Port Shape = None, нажать Ok и щелкнуть LB 
в точках  217 /155 ,   222,5 /222,5,   122,5 /210. 

8.  Командой Place > Text заполнить поля  «Цепь» на разъеме согласно рисунку 36. 
9.  Выполнить проверку схемы на отсутствие ошибок (по команде  Utils > ERC). 
10.  Сформировать список цепей для конструкторского проектирования ПП командой: 

Utils >Generate Netlist в окне Netlist Format выбрать значение P–CAD ASCII 
11.  Установить флажок в поле Include Library Information, щелкнуть LB на кнопке Ok – 

списку цепей будет присвоено имя проекта (Test) и расширение NET 
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20. Разработка схемы с иерархией        

Создадим схему регистра сдвига (рис.37), содержащую четыре D–триггера (рис. 38). 
Шаг 1.  Создание символа D-триггера (модуля DT). 
1. В редакторе Schematic открыть файл ShablonSCH и подключить библиотеку Test. 
2. Командой Utils > Module Wisard запустить «Мастер создания модуля». 
3. В окне Module Wisard щелкнуть LB на строке Create a new module and its link (созда-
ние нового модуля), кнопке Next – и в новом окне установить поля: Module Name = 
DT; Number of input pins = 2 (входные контакты D и C), Number of output pins = 2 
(выходные контакты  Q и ~ Q), Symbol Width = 12.5mm (ширина символа – здесь и 
далее размерность вводить обязательно), Pin Length = 5mm (длина вывода), Pin Spac-
ing = 5mm (расстояние между выводами). 

4. Установить флажок Create Corresponding Link и поле Link Name = LN (имя подсхемы) 
5. Установить флажок Save in library и выбрать библиотеку Test, 
6. Ввести имена контактов, для чего: в поле Pin Designator ввести 1 нажать клавишу Tab, в 

поле Pin Name ввести D и нажать клавишу Enter; аналогично ввести имена остальных 
выводов и нажать кнопку NEXT – откроется третье окно Module Wisard. 

7. Щелкнуть LB на строке Sheet1 и кнопке NEXT – откроется 4-е окно Module Wisard; 
8. Система предложет имя RefDes = M1, с которым можно согласиться, щелкнув LB на 

кнопке OK, – система  перейдет в режим Place>Part – шаг 1 завершен. 
Шаг 2.  Создание схемы сдвигового регистра 
1. Установить сетку = 5 мм и щелкнуть LB точке 80/100 – модуль появится на схеме. 
2. Пользуясь сочетанием клавиш CTRL+LB, привести графику символа M1 к виду на рис.37 

 

Рис. 37 Рис.38 
3. После Edit >Select щелкнув LB на модуле M1, нажать CTRL+LB и отпустить LB по-

следовательно в точках  110/100, 140/100 и 170/100 – модули М1М4 установлены.  
4. Командой Place > Wire  построить цепи согласно рисунку 37.  
5. После Place > Part установить контакты разъема ON-KS-10 и подключить их к кон-

тактам DSR, Shift и EXIT, после чего присвоить цепям имена – шаг 2 завершен. 

Шаг 3.  Создание подсхемы 
1.  Для начала создания схемы D-триггера: щелкнуть LB и RB в центре M1, выбрать 
строку Descend и в окне Hierarchy Navigator дважды щелкнуть LB на контакте 1 – от-
кроется новый лист DT (контроль – в строке статуса). 

2. Перенести контакты: №1 – в точку  25/100, №2 – в точку  25/50, №3  – в точку  
160/100 и №4 – в точку  160/50; например,  для переноса контакта 1 в точку  25/100: 
 щелкнуть LB и RB в центре контакта и в меню щелкнуть LB на строке Properties; 
 выбрать закладку Symbol, в поле Location установить: X=25, Y=100 и нажать OK. 
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3. Установить символы на схему и соединить их цепями согласно рис. 38. 
4. Перейти назад – в схему сдвигового регистра и сохранить проект этапами: 
 щелкнуть LB и RB в центре контакта 1 и в меню щелкнуть LB на строке Ascend – 
откроется окно Hierarchy Navigator  с перечнем модулей сдвигового регистра; 

 щелчком LB на модуле M1 вернуться в схему сдвигового регистра. 
 после File>Save сохранить проект на диске как Shift-R. 
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21. Ввод схемных обозначений по ЕСКД       

Ввод схемных обозначений по ЕСКД предполагает замену системных обозначений 
вида DD1:1, DD1:4  и т.д. на DD1.1, DD1.4  и т.д. Выполним эту процедуру этапами: 
 в редакторе Schematic открыть файл Test.sch.  
 щелкнуть LB и RB  в центре символа DD1:1 и на строках: Properties> Attributes> ADD> 

Component> (user-defined) – откроется окно Place Attribute; 
 установить: Name=RD1, Value=DD1.1, Text Style=DefaultTTF, установить флажок в поле 

Visible, выбрать центральную точку в поле Justification и нажать OK>OK; 
 погасить атрибут Refdes= DD1:1 и переместить на его место новый атрибут DD1.1. 
 щелкнуть LB и RB  в центре символа DD1:4 и снова открыть окно Place Attribute. 
 установить: Name=RD4, Value=DD1.4, Text Style=DefaultTTF, установить флажок в поле 

Visible, выбрать центральную точку в поле Justification и нажать OK>OK;  
 погасить атрибут Refdes = DD1:4 и переместить на его место новый атрибут DD1.4 

22. Вывод схемы на принтер          

1. В редакторе Schematic загрузить ПЭС Test.sch (File > Open) 
2. После File > Print Setup  установить формат листа принтера А3 и щелкнуть LB на Ok. 
3. После File > Print щелкнуть LB на строке Sheet1 – строка будет выделена. 
4. Снять флажок Current Windows, установить флажок Scale to Fit Page и щелкнуть LB 

на кнопке Page Setup – откроется окно «Sheets». 
5. Щелкнуть LB на строке Sheet1 и установить флажки: Title, Rotate и Sheet Extents. 
6. В окне «Image Scale»  установить User Scale Factor (Масштаб) = 1.0. 
7. После Update Shee t>Close >Generate Printouts – пойдет печать схемы на принтер. 
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23. Разработка шаблона печатной платы       

Шаг 1. Разработка форматки ПП.выполним на основе форматки из раздела18. 
1. В редактрое Schematic командой File > Open открыть файл A3-RUS.TTL 
2. Записать в папку проекта файл со штампом в формате DXF этапами:  
 после File > DXF Out >Sheet1> Мm в окне «Output Mode»  установить все флажки; 
 щелкнув LB на кнопке DXF Filename, установить путь к папке проекта и указать имя 

файла (например, A3-RUS) и щелкнуть LB на кнопках Сохранить и OK. 
3. Загрузить редактор P-CAD PCB и открыть файл ShablonPCB (File > Open). 
4. Прочитать файл со штампом в формате DXF, для чего: по команде File > Import  > 

DXF   открыть файл A3-rus.DXF и в окне File DXF In щелкнуть LB на: Мm > Auto 
Ajust to Workspace > Sheet1> Map Selected Layers> OK. 

5. После File >Save As сохранить форматку как A3-rus.PCB,  (   Тип файла = Binary Files) 

Шаг 2. Разработка шаблона ПП 
1. Очистить рабочее поле командой: Edit >Select All >Edit > Delete (настройки сеток, 

шрифтов и линий будут сохранены). 
2. Записать шаблон ПП на диск под именем ShablonPCB, по команде  File > Save. 
3. Покинуть редактор РСВ:  File > Exit 
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24. Поиск в библиотеках         

Элементами – объектами поиска в библиотеках выступают компоненты. Поиск 
осуществляется на основе запросов, которые оформляются в виде совокупности кри-
териев, формируемых в таблице запросов (ТЗА) в окне Query, открываемом командой 
Library > Query. Пример ТЗА приведен в табл.18. Она содержит следующие строки: 
Component Name (Имя компонента), Component Library (Имя библиотеки), Component 
Type (Тип компонента), NumberOfPads (Число КП), NumberOfPins (Число выводов), 
NumberOfParts (Число символов в корпусе), RefDesPrefix (Имя компонента), PatternName 
(Имя ПМ), ComponentHeight (Высота компонента), Component Name (Имя компонента).  

Порядок строк в ТЗА определяет порядок следования столбцов в таблице отчета 
о найденных компонентах (ТОК), формируемой в процессе поиска. В ТОК перечисля-
ются элементы библиотек, удовлетворившие критериям поиска. Критерии задаются в 
строках ТЗА и одновременно являются заголовками столбцов ТОК. 

В табл. 18 приведена ТЗА с запросом: «в открытых библиотеках найти компонен-
ты, имена ПМ которых начинаются с букв N или K». Запрос сформирован этапами: 
 в редакторе Schematic подключить библиотеки: NazaLib и MountLib. 
 командой Library > Query запустить мастер поиска. 
 проверить установку флажков против имен обеих библиотек в поле Open Libraries. 
 щелкнуть LB на кнопках Clear ALL и Set ALL – получена ТЗА вида табл.18. 
 щелкнуть LB на имени ComponentLibrary и далее на появившейся кнопке «»  и на 

строке PatternName – на 2-е место будущей ТОК поставлен столбец PatternName. 
 щелкнуть LB на имени ComponentType, на кнопке «»  и на строке ComponentLi-

brary – на третье место будущей ТОК поставлен столбец ComponentLibrary. 
 отключить остальные критерии, дважды щелкнув LB против них в столбце Show ТЗА 
 сформировать запрос в виде шаблонов N* и K* (в табл.18) – ТЗА построена. 
 реализовать запрос, щелкнув LB на кнопке Query – на экран будет выдана ТОК в 

виде, приведенном в табл.19. 
Таблица 18      Таблица 19 
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25. Перенос проекта Э3 в проект на ПП        

1. В редакторе PCB открыть файл ShablonPCB и установить сетку = 10 мм. 
2. Командой  Library  > Setup > Add из каталога проекта подключить библиотеку Test 
3. Командой  Utils  > Load Netlist…  из каталога проекта загрузить список соединений  

test.net, установив  поле Netlist Format = P–CAD ASCII – на экране появятся все ЭРЭ 
4. Назначить клавиши Ctrl+L (Ctrl+H) для высвечивания (гашения) связей этапами: 
 после Macro>Record в окне Macro Recorder ввести имя LightNets и щелкнуть LB на кноп-

ке OK –  будет показана панель создания макроса; 
 после Edit >Select >Edit >Nets >Set All >Show >Close закрыть макрос, щелкнув LB на 

левой кнопке панели макроса,  – панель исчезнет, а макрос будет добавлен в библиотеку 
макросов  (аналогично вести макрос гашения связей HideNets) 

 командой Options>Preferences>Macros назначить «горячие клавиши» для сформирован-
ных макросов. 

5. Командой Select >Edit >Nets >Set All >Show Only On Drag >Close  установить режим 
показа связей,  появляющихся только при перемещении элемента по плате. 

6. Скрыть изображение типов и номиналов ЭРЭ: после Edit>Select заключить в окно 
все ЭРЭ, щелкнуть RB и, выбрав строку Properties, погасить флажки Type и Value. 

7. После File >Save As сохранить файл как Test.PCB,  ( Тип файла = Binary Files). 
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26. Ввод базовой конструкции ПП         

1. В редакторе PCB открыть файл Test, установить сетку = 5 мм и подключить биб-
лиотеку Holes командой Library >Setup. 

2. Ввести размеры базовой ПП =   5  4 мм этапами:. 
 после Options >Layers дважды щелкнуть LB на слое Board – он  станет текущим; 
 после Place>Line установить ширину линии 0,2 мм и щелкнуть LB в точках: 110/60, 

160/60, 160/100, 110/100,  110/60,  – щелкнуть RB, –  контур построен. 
3. Установить на ПП монтажные отверстия N6p0-2p7C этапами: 
 после Place >Component в окне Library выбрать библиотеку Holes и дважды щелкнуть 

LB на имени отверстия N6p0-2p7C – отверстие будет выбрано из библиотеки; 
 щелкнуть LB в точках: 115/65 , 155/65 , щелкнуть RB. 
4. Сохранить проект командой File >Save As как test–k 

 

27. Ручное размещение проекта          

1. Командой Options >Grids установить сетку чертежа = 1.25 мм и выполнить ручную 
расстановку ЭРЭ на плате. Например, VT1 ставится на ПП этапами: 

 по команде Edit >Select  щелкнуть LB в центре элемента VT1; 
 нажать LB и отпустить LB в точке 130/85 , – щелкнуть клавишей «R»; 
 аналогично перенести остальные ЭРЭ в точки, указанные в табл.20; 
2. Сохранить файл командой File >Save >Save As как Test–R. 
                                  Таблица 20 

ЭРЭ Координаты ЭРЭ Координаты  ЭРЭ Координаты  

X Y X Y X Y 
VD1 115 76.25 C1 125 63.75 R1 135 85  (RRR)
DD2 115 90 L1 155 70  {R} C2 125 70 
R2 140 65 DD1 140 90 R3 151.25 75 {R} 

VT1 130 85(R) X1 127,5 97,5    
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28. Ручная трассировка проекта         

1. В редакторе PCB загрузить проект TEST–R.PCB. 
2. Объединим цепи питания – в класс PWR, для чего: после Option >Net Classes – 

установить:  Class Name = PWR, щелкнуть LB  на кнопке ADD и в окне Unassigned 
Nets  дважды щелкнуть LB на +5B и GND и кнопке Close –  класс PWR построен. 

3. Аналогично построить класс SIG на базе остальных цепей из окна Unassigned Nets. 
4. Для класса PWR ввести значения ширины проводников = 0.7 мм, для чего: щелк-

нуть LB на кнопках: Option>Net Classes>PWR>Edit>ADD> Net >Width и, устано-
вив поле «Value» = 0.7, щелкнуть LB  на  кнопках OK> OK >Close – атрибут будет 
добавлен в таблицу атрибутов цепей. 

5. Аналогично ввести ширину проводников сигнальных цепей, равную 0.3 мм.  
6. Выполнить подготовительные операции для «ручной» трассировки ПП этапами: 
 после Option >Grids установить шаг сетки трассировки = 1.25 мм; 
 после Option>ViaStyle сформировать стиль переходного отверстия (ПО) V1p4_0p8C и 

сделать его текущим (команда аналогична Option>Pad Style – раздел 4); 
 включить панель инструментов трассировки командой View > Route Toolbar. 
7. Ввести топологические зазоры, для чего после: Option >Design Rules >Design,  щел-

кая клавишей Delete,  очистить окно Place Attribute и нажать кнопку OK. Далее вве-
сти первый зазор (LineToLineClearance – зазор  между проводниками) этапами: 

 по команде Option >Design Rules >Design >ADD  в окне «Place Attribute» последова-
тельно щелкнуть LB на строках: Clearance и LineToLineClearance;  

 в окне «Value» ввести значение зазора 0.3 и щелкнуть LB на кнопке OK;  
 такие же зазоры ввести для категорий: ViaToPadClearance – между ПО и КП, Vi-

aToLineClearance – между ПО и проводником, PadToLineClearance – между КП и провод-
ником, LineToLineClearance – между проводниками, ViaToViaClearance – между ПО и 
ПО, PadToPadClearance – между КП и КП. 

8. Разрешить выбор всех направлений ведения ручной трассы: по команде Option > 
Configure>Router… установить флажки во всех строках поля  Orthogonal Mode. 

9.  По команде Option >Online DRC… установить флажки во всех полях, в результате 
чего: 1) все ошибки будут вывялятся, и 2) сообщения об ошибках (Report Options) 
будут появляться вплоть до полного их устранения. 

10.  Установить порядок проверки зазоров этапами: 
 после Utils >DRC… установить все флажки в поле Report Options; 
 перевести нарушения зазоров из разряда предупреждений в разряд ошибок, для чего: а) 

щелкнуть LB на кнопке Severity Levels;  б) в колонке Rule щелкнуть LB на строке 
Clearance;  в) в поле Severity Levels щелкнуть LB на Error и на на кнопке ОК; 

 перевести нарушения Unconnected Pins – не окрашенные контакты из разряда ошибок в 
разряд предупреждений, для чего: а) щелкнуть LB на кнопке Severity Levels;  б) в колон-
ке Rule щелкнуть LB на строке Unconnected Pins;  в) в поле Severity Levels щелкнуть LB 
на слове Warning и на на кнопке ОК; 

 в поле «Design Rule Checks» установить все флажки, кроме первого и последнего, и 
щелкнуть LB на кнопке ОК (стр 456 - Уваров); 
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 ограничить область DRC размерами ПП: после Region > Define Region нажать LB около 
точки 105/105  и отпустить LB около  170/50, далее щелкнуть RB и щелкнуть LB на 
кнопках «Да» и ОК – будет выполнен DRC и сохранены введенные правила; 

 включить DRC, щелкнув LB на кнопке DRC панели инструментов Command Toolbar. 
11. Снова сохранить файл в папке проекта под именем TEST–R. 
12. Построить трассу А1 между выводом 1 элемента С1 и выводом 6 –  DD1 этапами: 
 после Select>Edit>Nets>SetAll>Hide>A1>Show >Close  - цепь А1 будет выделена на 

экране синим цветом; 
 после Route>Manual  клавишей «О» установить режим проведения ортогональных 

трасс: контроль исполнения – в правом углу строки состояния (Ortho=90); 
 щелкнуть LB в точке  132,5/63,75 – цвет цепи А1 станет белым; 
 переместить курсор в точку 137,5/63,75  и щелкнуть LB – будет построен отрезок про-

водника в слое TOP; 
 нажать клавишу «L» – слой BOTTOM станет текущим, щелкнуть LB в точке  137,5/77,5 

– будет сформировано ПО и построен 2-й проводник (в  слое Bottom); 
 нажать клавишу «L» – текущим станет слой TOP, щелкнуть LB и RB в точке 140/77,5 –  

требуемый участок построен. 
13.  Построить участок трассы А1 от нижнего вывода R3 до 6-го вывода DD1 этапами: 
 после Route > Manual щелкнуть LB в точке  140/77,5 – цепь будет выделена; 
 щелкнуть LB в точках  140/76,25  и  151,25/76,25 , после чего щелкнуть RB –  требу-

емый участок будет построен, причем заключительный проводник будет доведен  
автоматически, если в поле Manual Route (Options > Config-
ure > Route)  установлен флажок – Right Mouse… . 

14. Построить участок трассы А1 от нижнего контакта R3 до 
контакта DD1 (рис.  39). 

15. Остальные цепи построить в режиме (Route >Interactive), 
который отличается от режима Route >Manual жестким 
DRC и возможностью автоматического соединения марш-
рута по заданным (щелчком LB) конечным точкам Рис.  39 
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29. Введение/удаление вершин изгиба проводников       

1. В редакторе PCB загрузить проект test–t и включить DRC, для чего после Options 
>Configure >Online DRC   установить флажок в поле Enable Online DRC. 

2. Показать неразведенные связи командой Edit>Select>Edit>Nets>SelectALL>Show. 
3. Построить последний не разведенный участок цепи +5B этапами: 
 после Route >Manual клавишей L  сделать текущим слой Top, щелкнуть LB в точке 

147,5/90  – трасса +5B  подсветится, курсор примет форму косого креста, а ширина про-
водника станет равной 0,7 мм;   

 щелкнуть LB в точках  147,5/91,25 –  127,5/91,25  – 127,5/90 – трасса будет построена, но 
система выдаст предупреждение о нарушении правил соблюдения зазоров. 

4. Удалить значки, предупреждающие о несоблюдении зазоров (Info Point)  этапами: 
 щелкнуть LB в точке 147,5/91,25 – откроется табличка выбора 
 щелкнуть LB на строке InfoPoint и нажать клавишу «Delete» - значок исчезнет; 
 аналогично удалить InfoPoint в  точке 140/91,25; 
5. Перенести построенный горизонтальный проводник выше на один дискрет этапами: 
 щелкнуть LB в точке 135/91,25 –  проводник будет выделен; 
 нажать  LB  и, не отпуская LB, перетащить курсор в точку 135/92,5 – отпустить LB,  – 

появится значок  InfoPoint и сообщения о не соблюдении зазора;  
 закрыть окно сообщения и удалить InfoPoint. 
6. Устранить конфликтную ситуацию, отмеченную в предыдущем пункте этапами: 
 выключить DRC и ввести вершину в центр горизонтального проводника: после Edit 

>Select щелкнуть LB и RB в точке 132,5/92,5  и выбрать строку Add Vertex – готово;  
 аналогично добавить еще две вершины в точки: 132,5/92,5 и 135/92,5; 
 перетащить вершину из точки 132,5/92,5   в точку 131,25/92,5; 
 аналогично перетащить вторую вершину из точки 137,5/92,5   в точку 136,25/92,5 
 включив DRC, перетащить 3-ю вершину из точки 135/92,5  в точку 133,75/91,25 
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30. Режимы ARC и Tangent ARC, перенос трасс        

1. Выполнить пункты 1-2 предыдущего раздела. 
2. Построить участок цепи +5B, используя режим ARC этапами:  
 после Route >Manual  щелкнуть LB в точке 127,5/90, и, нажав LB в точке  

131,25/92,5, выбрать клавишей «О» режим ARC (контроль в строке статуса); 
 отпустить LB, щелкнуть LB в точке  133,75/90 , и затем в точках: 137,5/90 , 

137,5/92,5 , 147,5/92,5,   щелкнуть RB (трасса построена). 
3. Стереть построенный проводник инструментом Undo ( ). 
4. Построить не разведенный участок цепи +5B, используя режим Tangent ARC: 
 после Route >Manual щелкнуть LB в точке 127,5/90, выбрать режим ортогонального 

проведения трасс  и щелкнуть LB в точках: 127,5/92,5 и  131,25/92,5;   
 выбрать режим Tangent ARC и щелкнуть LB в точках: 133,75/91,25, 136,25/92,5, 

147,5/92,5 – щелкнуть RB (трасса построена). 
5. Перенести проводник, пересекающий точку 120/92,5 ,  в слой TOP этапами: 
 щелкнуть LB в точке 120/92,5  – проводник будет выделен; 
 слой TOP сделать активным, выбрав его в строке статуса; 
 выполнить команду Edit >Move To Layer – проводник будет перенесен в слой TOP, при-

чем оба контактных перехода будут аннулированы. 
6. Аналогично перенести в альтернативные слои проводники, пересекающие точки  

122,5/76,25 , 122,5/66,25 , 136,25/63,75 , 152,5/70 , 142,5/70. 
7. Сохранить файл в папке проекта под именем TEST–R–TangentAfter.PCB. 

 



 39

31. Сглаживание изгибов проводников         

1. В редакторе PCB открыть проект TEST–T–TangentAfter.PCB. 
2. По команде  Options>Configure>Route  в поле «Miter Mode» установить флажок в 

строке Line, задающий режим сглаживания углов под 45 градусов. 
3. После View>Extent   установить курсор в точку 130/85  и дважды нажать серый плюс 
4. Выполнить сглаживание прямого угла в точке 132,5/85, для чего: активизировать ко-

манду Route>Miter, нажать  LB в точке 132,5/85  и отпустить – в точке 131,25/83,75. 
5. Сохранить проект в папке проекта под именем  TEST–T-After.PCB  

 

32. Трассировка жгута          

Подготовка примера для демонстрации.  
1. В редакторе PCB открыть ShablonPCB, подключить библиотеку Test и сетку = 1,25 мм.  
2. Установить элемент 133LA6 в точки 50/40 и 77,5/55 и сделать текущим слой – TOP. 
3. Командой Place>Connection соединить контакты 14, 13, … , 8  DD1 с контактами 14, 

1, 2,  … , 8 ИМС DD2  соответственно.  
4. Включить сетку 0.625 мм и сохранить файл как Shina.PCB – пример подготовлен. 
Трассировка жгута.  
1. Включить режим показа всех связей: Edit >Select >Edit >Nets >Set All >Show >Close.  
2. После Route >Fanout построить отводы от правого ряда контактов DD1 этапами: 
 при нажатой клавише CTRL щелкнуть LB последовательно в каждом правом кон-
такте DD1, после чего щелкнуть RB и выбрать строку Fanout ; 

 на  сообщение 12120 («Выбранные связи выровнены по обоим концам. Для трасси-
ровки жгута щелкните LB около одного из концов») ответить OK, щелкнуть LB в 
точке 65/40, привести открывшееся окно к виду (рис.40) и нажать OK – рис.41. 

3. После Route >Multi Trace щелкнуть LB в точках 80/37,5 и 60/56,25 –   связи выде-
ляться. Нажать RB и в меню щелкнуть LB на строке Complete – жгут построен. 

 

Рис.40 Рис.41 
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34. Внесение изменений в проект         

1. Прямое внесение изменений (из Э3 на ПП) 
Изменить  имя цепи А2 на A22 и  добавить параллельно резистору R2 новый рези-

стор R4 синхронно в проектах Test.sch и Test-R.pcb можно этапами: 
 в редакторе Schematic загрузить проект схемы Test.sch, куда вносятся изменения; 
 запустить запись изменений в файл изменений: Utils>Record ECOs>On >OK 
 переименовать цепь A2, для чего после Edit>Nets в окне Net Names щелкнуть LB на име-
ни цепи A2, на кнопке Rename, ввести имя A22 и щелкнуть LB на кнопках OK и  Close; 

 командой Place > Part   добавить на схему резистор R4 в точку 130/180; 
 командой Place > Wire   подключить резистор R4  параллельно R2; 
  сохранить внесенные изменения в «файле изменений» командой File > Save >  

Append ECOs To File > File > Save – будет сформирован файл Test.eco– текстовый 
файл, состоящий из 4-х строк: 1) NetRename "A2" "A22" 2) CompAdd "C2-33" "R4"  
3) NetNodeAdd "STROB" "R4-2" 4) NetNodeAdd "INP" "R4-1", представляющих ко-
манды произведенных изменения в проекте; 

 запустить редактор PCB (командой Utils > PCAD – PCB); 
 загрузить проект на ПП Test-R.pcb из папки проекта (командой File > Load ); 
 загрузить и просмотреть «файл изменений» из папки проекта:  после Utils > Import 

ECOs…> ECOs File Name…   в окне «Utils Import ECOs» ввести имя «файла изме-
нений» Test.eco и нажать кнопку Preview ECOs; 

 внести изменения в проект на ПП, для чего закрыть Блокнот и нажать кнопку ОК; 
 сохранить изменения в проекте на ПП командой File > Save. 

2. Обратное внесение изменений (из ПП на Э3) 
Пусть требуется изменить имя цепи STROB на А2 и  удалить из проекта R3в проекте 
на ПП (Test-R.pcb). Чтобы изменения отразились и в проекте на ПП и в проекте схемы 
(Test.sch), необходимо все изменения вносить в следующем порядке: 
 в редакторе PCB загрузить файл test-r.pcb, куда вносятся изменения; 
 запустить запись в файл изменений: Utils > Record ECOs… > On > OK; 
 выполнить изменение имени цепи: после Edit > Nets щелкнуть LB на имени цепи 

STROB, на кнопке Rename и ввести новое имя A2 и щелкнуть LB на OK и Close; 
 щелкнуть LB и RB на ЭРЭ R2 и, щелкнув LB на строке Delete, удалить R2; 
 сохранить изменения в файле изменений командой File > Save >  Append ECOs To 

File > File > Save –будет сформирован файл Test-R.eco, содержащий строки: 
NetRename "STROB" "A2"         
NetNodeDelete "INP" "R2-1"      
NetNodeDelete "A2" "R2-2"      
CompDelete "R2" 

 в редакторе Schematic загрузить проект на схеме Test.sch (командой File > Load ); 
 для просмотра файла изменений:  после Utils > Import ECOs…> ECOs File Name…   
в окне Utils Import ECOs ввести имя Test.eco и нажать кнопку Preview ECOs; 

 внести изменения в проект на схеме, для чего закрыть Блокнот и нажать кнопку ОК; 
 сохранить изменения схемы на диске командой File > Save и покинуть редактор. 
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3. Прямая модификация вентилей готового проекта. 
Пусть произошла модификация библиотеки Test.lib и разработчик схемы (файл 

Test.sch) принял решение модифицировать вентили микросхемы DD2 в проекте, для 
которого уже выполнена ручная трассировка (файл Test-H.Pcb).  Прямые изменения 
вносим этапами: 
 в редакторе Schematic загрузить проект схемы Test.sch, куда вносятся изменения; 
 запустить запись в файл изменений: Utils > Record ECOs… > On > OK; 
 удалить вентили DD2:1 и DD2:2 из схемы, для чего после Edit > Select, удерживая 
клавишу CTRL, щелкнуть LB на указанных вентилях и нажать клавишу Delete; 

 установить новые вентили DD2:1 и DD2:2 на прежние места из  библиотеки Test;  
 сохранить изменения в файле Test.eco: File>Save>Append ECOs To File>File>Save; 
 в редакторе PCB загрузить проект на Test-TH.pcb; 
 загрузить и просмотреть «файл изменений» из папки проекта:  после Utils > Import 

ECOs > ECOs File Name… в окне Utils Import ECOs ввести имя «файла изменений» 
Test.eco и нажать кнопку Preview ECOs; 

 внести изменения в проект на ПП, для чего закрыть Блокнот и нажать кнопку ОК – 
«старая» микросхема DD2 будет удалена из проекта вместе с примыкающими к ее 
контактам «хвостами» проводников; 

 установить режим показа связей командой Select > Edit >Nets >Set All >Show> 
Close и перенести микросхему DD2 на ее прежнее место в точку 115/90; 
 восстановить недостающие «хвосты» в режиме ручной разводки (раздел 25.4); 
 сохранить изменения на диске командой File > Save и покинуть редактор PCB. 

4. Принудительная замена микросхемы на ПП. 
Пусть произошла модификация микросхемы 133LA6 в библиотеке Test.lib в части из-
менения ПМ. В этом случае модификации схемы не требуется и  разработчик, минуя 
механизм ECO, может просто заменить микросхему  DD2 на ПП этапами:   
 в редакторе PCB загрузить проект Test-TH.pcb, куда вносятся изменения; 
 щелкнуть LB на микросхеме DD2 – произойдет ее «выделение»; 
 выполнить команду: Utils > Force Update – откроется окно «Force Update»; 
 щелкнуть LB на строке 133LA6, кнопке Update и, ответив «Да» на сообщение о 
том, что данную операцию невозможно отменить, – закончить модификацию. 
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35. Металлизированные отверстия для МПП        

Площадки, имеющие различную форму и/или правила подключения в разных слоях, 
создаются в режиме Modify (Complex). При создании таких КП: на 1-м этапе создается 
структура слоёв МПП, а на 2-м – собственно площадка. 
1. В редакторе РСВ открыть файл Test-R.PCB и сохранить его как MPP-R. 
2. Создать внутренние слои Int1 Int2 Int3 и Int4 с параметрами установок Signal и Auto 

(например, слой Int1 создается  так: после Options > Layers  установить поля Layer 
Name=Int1,  Type=Signal ,  Routing Bias=Auto и щелкнуть LB на кнопке ADD). 

3. Создать экранный слой PL,  подключив его к цепи +5V. 
4. Создать КП для МПП квадратное в слоях Top и Bottom и круглое  – в остальных: 
 по команде Options >Pad Style > Copy ввести имя площадки MPO, нажать Ok и 
дважды щелкнуть LB на строке MPO – отверстие станет текущим; 

 по команде Options >Pad Style > Modify (Complex) для слоев Top и Bottom, уста-
новить поля: Shape = Rectangle, Width=Height= 1.4, Diameter = 0.8, установить 
флажок в окне Plated и нажать Modify; 

 для слоя Signal: Shape = Ellipse, Width= Height= 1.4 и нажать Modify;  
 для слоя Plane: Shape = Ellipse, Inner Dia=1.4 (равен размеру КП в слое TOP) Out 

Dia=2 (равен 1.4+2*0,3=2 мм) и нажать Modify; 
 щелкнуть LB на кнопке OK – произойдет возврат в окно Options Pad Style; 
 щелкнув LB на кнопке Modify Hole Range,  просмотреть структуру созданной КП;  

5. Создать  ПО MPO12-0p8C (между слоями 1 и 2 МПП диаметром 0,8 мм) этапами: 
 по команде Options>ViaStyle>Copy ввести имя MPO12-0p8C, нажать OK и дважды 
щелкнуть LB на строке MPO12-0p8C – отверстие станет текущим; 

 после Options > Via Style > Modify (Simple) установить поля: Type=Thru, Shape= El-
lipse, Width=Height=1.4, Diameter=0.8, установить флажок Plated и нажать OK; 

 щелкнув LB на кнопке Modify Hole Range в открывшемся окне выделить строку 
MPO12-0p8C, и в режиме Drug and Drop –   строки:  Int1, Int2;  

 по команде OK >Close  завершить создание ПО.  
6. Сохранить проект MPP-R .PCB в папке проекта командой File > Save. 
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36. Создание сплошных областей металлизации       
Решим далее следующую задачу: зальем в проекте MPP-T.PCB все свободные участки 
МПП медью в слоях Top и Int1 и соединим всю заливку с цепью +5V. 
1. Загрузить проект MPP-T.PCB  из папки проекта командой File > Load. 
2. Далее создадим в слое Top область заливки и подключим ее к цепи +5B этапами:  
 в слое  TOP командой Place>CopperPour задать полигон заливки, щелкая LB в точ-
ках: 112.5/61.5, 112.5/98.75,  158.75/98.75,  158.75/61.25, после чего – щелкнуть RB;  

 после Edit>Select выделить область заливки, щелкнув LB и RB в точке 11.25/98.75;  
 выбрать в меню строку Properties – откроется окно Copper Pour Properties;  
 на закладке Style  установить: Back Off = Fixed и задать значение зазора между за-
ливкой и проводниками схемы = 0,4 мм, Back Off Smoothness = High (высокая точ-
ность исполнения радиусов области заливки); в поле «State» = Poured (залить); 

 на закладке Connectivity установить: Net=+5B, оба поля Stroke Width = 0.3 мм (ши-
рина термоперемычки) и щелкнуть LB на кнопке Ok – область заливки будет 
сформирована и подключена к цепи +5B.  

3. Удалить островки площадью менее 200 мм2 , для чего в окне Copper Pour Properties, 
(п.2) на закладке Island Removal  установить флажок в поле Minimum Area  и в со-
седнем окне ввести значение 200 - щелкнуть LB на Ok –  часть островков исчезнет.  

4. Соединить островок, накрывающий точку 135/80, с цепью +5B через слой Int1:  
 после Edit>Select щелкнуть LB в точке 160/60 – снято выделение области заливки;     
 после Edit>Nets>SelectAll>Show просмотреть изолированные области (1-я область 
накрывает точку, 115/75 , 2-я область –145/80 и  3-я область – 135/80; на изоля-
цию областей от цепи +5B указывает синяя линия – связь не подключенной к 
этим островкам цепи +5B) и сделать доступным только слой Int1;     

 командой Place>Copper Pour задать полигон заливки, щелкая LB в точках: 
11.25/61.25,  11.25/98.75,  58.75/98.75,   58.75/61.25, после чего – щелкнуть RB;  

 после Edit>Select выделить контур заливки, щелкнув LB в точке 11.25/98.75;     
 щелкнуть RB и выбрать строку Properties – откроется окно Copper Pour Properties;  
 на закладке Style  установить: «Back Off» = Fixed и задать значение зазора между 
заливкой и проводниками схемы = 0,4 мм, «Back Off Smoothness» = High (высокая 
точность исполнения радиусов области заливки); в поле «State» = Poured (залить); 

 на закладке Connectivity установить: Net=+5B, оба поля Stroke Width = 0.3 мм и 
щелкнуть LB на кнопке Ok – область заливки построена и подключена к цепи +5B.  

 сделать доступным только слой Top, для чего после Options>Layers дважды щелк-
нуть LB на строке Top и  выполнить команду: Options>Layers>Diabled ALL> Close;     

 после Options>ViaStyle дважды щелкнуть LB на имени MPO – оно станет текущим; 
 установить ПО на МПП в точку точке 131.25/81.25, для чего активизировать ко-
манду: Place > Via и щелкнуть LB в указанной точке; 

 подключить ПО к цепи +5B, для чего активизировать команду: Place > Connection 
нажать LB в точке 125/90 (контакт питания DD2) и,  не отпуская LB, перетащить 
курсор мыши в точку 131.25/81.25,  после чего отпустить LB; 
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 последовательно выделить и повторно залить металлизированные области в слоях 
Int1 и Top командой Repour  в окне Copper Pour Properties. 

 

37. Ввод текстового описания схемы       
Формат описания ПЭС в текстовом виде практически совпадает с форматом  

обычного ALT–файла системы  PCAD-4/5. Выполним подготовку и ввод ALT–файла, 
для схемы, приведенной на рисунке 36 в разделе 22. 
1. Подготовить текст ALT–файла TEST.ALT (рис.  42). Есть три особенности его под-

готовки: во-первых,  PCAD-2002 игнорирует оператор board=plata.pcb; (сам файл 
PLATA.PCB так же может отсутствовать, однако, наличие этого оператора является 
обязательным);  во-вторых, обязательно наличие ЭРЭ в библиотеке проекта (в биб-
лиотеке Test); в-третьих, в конце ALT-файла  отсутствует оператор EndSheets. 

2. Выполнить ввод списка цепей для конструкторского проектирования этапами: 
 в редакторе PCB загрузить шаблон ShablonPCB; и подключить библиотеку TEST; 
 после File >Save As  сохранить проект на диске под именем TestALT.pcb; 
 по команде Utils > Load NetList установить поле: Netlist Format = Master Designer ALT 
и, щелкнув LB  на кнопке Netlist File Name, установить путь к файлу TEST.ALT; 

 щелкнуть LB на кнопках Открыть и OK - файл списка цепей будет загружен, и на 
экране появятся все элементы проекта, но без контура ПП. 

BOARD=1.PCB; 
PARTS 
C2-3=R1,R2,R3; 
K73-15= C2; 
К10-43А= C1; 
KD403A =VD1; 
KT3102G =VT1; 
D1–1P2–1 = L1; 

K511PU2 = DD1; 
133LA6 = DD2; 
ON-KS-10 = X1; 
NETS  
A1= R3/1 C1/2 L1/1 DD1/6;A2= 
R2/2 DD1/9 DD1/3;A7  = DD1/1  
DD1/2 VT1/2 R3/2; 
A5 = DD2/4 DD2/5  DD1/10 X1/2; 
NET00005 = DD1/8 X1/3; 

A4  = DD2/8 DD2/1 DD2/2 DD1/12 DD1/13; 
+5B = DD1/14 DD2/14 L1/2 X1/1; 
GND = C1/1 DD1/7 DD2/7 R1/1  
      VD1/1 VT1/3 X1/7; 
INP = C2/1 R1/2 R2/1 VD1/2 X1/4; 
EXIT = DD1/11 X1/6; 
STROB = DD2/6 DD2/9 DD2/10 X1/5; 
A3= C2/2 VT1/1 DD1/4  DD1/5 DD2/12 
DD2/13; 

Рис.42 
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38.  Оптимизация цепей (Swap Gate)       

Данный этап выполняется перед началом трассировки ПП.  
1. Вначале в  редакторе Schematic создадим тестовую схему этапами: 
 открыть файл ShablonSCH,  ввести сетку = 1,25 и подключить библиотеку TEST. 
 после Place >Part установить элемент 133LA6 в точки:  90 /90 ,  140 /90  ,  170 /90   
и   200 /90  щелкнуть RB –  рис.  43 (без резисторов) 

Рис. 43 Рис. 44 
16. установить резисторы C2-33 согласно рисунку 43; 
 после Place>Wire построить проводники (рис.43) и сохранить проект как swap.sch;  
 по команде Utils >Generate NetList >Ok создать список цепей примера swap.net. 

2. Загрузить проект схемы на ПП этапами: 
 в редакторе PCB открыть файл ShablonPCB и установить шаг сетки = 1,25 мм; 
 подключить библиотеку TEST к проекту командой  Library > Setup; 
 по команде Utils >Load NetList загрузить на ПП список цепей SWAP.NET; 
 переместить R1 в точку 50/45  – R2 в точку 30/45  – DD1 в точку 30/35  – DD2 в 
точку 50/35  и установить текущим слой TOP –  рис.  44. 

3. Выполнить ручную оптимизацию цепей этапами: 
 после Utils >Optimize Nets  в одноименном окне щелкнуть LB по строке  Manual 

Gate Swap  и на кнопке OK – произойдет возврат в поле проекта на ПП; 
 щелкнуть LB в точке 30 /35  –   1-й вентиль, подлежащий обмену, будет выделен;  
 щелкнуть LB в точке 50 /35  –   второй вентиль, подлежащий обмену, будет выде-
лен и на экране появится таблица результатов подсчета СДС в виде:  

Net Name (Имя цепи) Manhattan Len… (длина СДС) Percent Change (Эффект)
A7 20.000 mm – 50% 

NET00002 11.250 mm  – 64% 
NET00003 20.000 mm 0 
NET00004 11.250 mm  – 64% 

 Total percent change (TPC):   – 49% 
 первая строка таблицы показывает, что длина цепи A7 после выполнения команды 

SWAP  уменьшится на 50 процентов и станет равной 20 миллиметрам и так далее;   
 текст (TPC) под таблицей, показывает средний процент уменьшения СДС всех цепей; 
 конструктор либо выполняет обмен: если TPC<0, то  щелкает LB на кнопке SWAP, 
либо аннулирует попытку обмена: если TPC>0, то щелкает LB на Cancel.  

4.   Автоматическая   оптимизация  цепей  произойдет  после  выполнения   команды:    
Edit > Select ALL> Utils >Optimize Nets>Gate Swap>Selected Objects>OK>Да 



 46

39. Копирование элементов библиотек        

 В программе Library Executive создадим новую библиотеку Rap и выполним копи-
рование в нее всех символов, посадочных мест и компонентов из библиотеки Test.   
1. Создать новую библиотеку Rap, для чего: после Library > New   ввести в поле Имя 
файла имя Rap и нажать кнопку Сохранить. 

2. Подключить к проекту библиотеки Test (источник) и  Rap (приемник) этапами: 
 после Library>Copy>Source Library (библиотека-источник) дважды щелкнуть LB на 
имени библиотеки Test  - путь к библиотеке появится рядом с кнопкой Source Library; 

 так же подключить библиотеку Rap, воспользовавшись кнопкой Destination Library; 
3. Выполнить копирование символов этапами: 
 в поле Copy Item установить флажок Symbol – список всех символов отобразиться в 
поле Multiply Sourse Name – нажать, далее, LB на первой строке этого списка и отпу-
стить – на последней: все копируемые символы будут выделены;  

 щелкнуть LB на кнопке Copy  –  появится сообщение о завершении копирования. 
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40.  Программа SPECCTRA: начало работы        

1. Перейти в программу SPECCTRA этапами:  
 в редакторе PCB загрузить файл Test-K и после Place>Autoplacement установить 
значение поля Autoplacer = SPECCTRA и щелкнуть LB на кнопке Command Line. 

 снять флажок в поле Quit when done, щелкнуть LB на кнопке Start и ответить  «Да» 
на предупреждения системы – откроется ГИП программы SPECCTRA; 

 в верхнем правом углу щелкнуть LB на обоих кнопках «Развернуть». 
Первая строка ГИП представляет заголовок и версию программы, вторая – ее 

главное меню, третья - это панель инструментов (ПИ). Пиктограммы  и  устанав-
ливают соответственно режимы размещения и трассировки.  

В табл.21 показана панель инструментов размещения. Назначение пиктограмм 
общего действия: Repaint – обновить экран; View All – полный обзор проекта; View 
Layers – обзор слоев; Reports – отчеты. Пиктограмы режимов: Select Comp – выбор 
ЭРЭ; Measure –измерение; Fix/Unfix – фиксация ЭРЭ; Move Comp – перемещение ЭРЭ; 
Push Comp – расталкивание ЭРЭ; Rotate – поворот ЭРЭ; Change Layer – смена слоя 
установки ЭРЭ; Trade Comp – обмен позициями ЭРЭ; Align Comp – выравнивание ЭРЭ.  

В табл.22 показана ПИ трассировки. Пиктограмы режимов: Select Net – выбор цепи; 
Select Wire – выбор проводников; Select Guide – выбор цепей в окне; Edit Route – ручная 
трассировка; Move Route – перемещение трассы; Critic Route – сглаживание трассы; Cut 
Segment – вставка точки излома проводника; Delete Segment – удаление проводника. 

Таблица 21 

         
Repaint View ALL View 

Layers 
Report Select 

Comp
Measure Fix / 

Unfix
Move 
Comp 

Push 
Comp

Rotate Change 
Layers 

Trade 
Comp

Align 
Comp

Таблица 22 

    
Select Net Select Wire Select Guide Edit 

Route 
Move Route Copy 

Route 
Critic 
Route 

Cut 
Segment 

Delete 
Segment
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41. Размещение ЭРЭ с помощью ГИП         

1. УСТАНОВКА ПРАВИЛ РАЗМЕЩЕНИЯ  
 перейти в режим размещения: File >Placement Mode (если команды нет, значит, она 
уже выполнена) и командой View>ALL вписать весь проект в экран;  

 отключить режим показа связей:  View >Unroutes >Off  (либо >Guides); 
 установить метрическую систему измерний кнопкой в правом  нижнем углу; 
 показать обозначения элементов: View>Labels>RefDes>OK. 
 задать одностороннее размещение: Rules>PCB>PermittedSide>Front >Apply>OK 
 установить глобальный зазор 0,5 мм  между всеми ЭРЭ: после Rules>PCB >Spacing 
установить: ALL = 0.5 и щелкнуть LB на кнопках Apply и OK ; 

 установить индивидуальный зазор 2 мм для Х1: после  Rules>Component>Spacing 
щелкнуть LB на: кнопке Pick Component, на имени разъема X1 и кнопке OK и, 
установив поле ALL=2,   щелкнуть LB на кнопках Apply и OK ; 

 установить сетку размещения  1,25 мм: после Autoplace>Setup ввести значение 
1.25  в поле  PCB Placemrnt Grid и щелкнуть LB на кнопках Apply и OK; 

 показать сетку размещения: View >Layers >Place Grid.    

2. РУЧНОЕ РАЗМЕЩЕНИЕ  
1. Точное размещение и фиксация разъема:  
 перейти в режим указания координат ЭРЭ: RB> PlaceComponents>XY Location 

(если строк нет – вы в режиме трассировки); 
 в поле Component выбрать элемент Х1 и, установив поля X=127.5 и Y= 95, щелк-
нуть LB на кнопках Apply и OK; 

 выполнить откат: Edit>Undo или CTRL+Z, вернуться в контекстное меню и вы-
брать режим Move Comp Mode  (в строке статуса появится фраза Move Comp);    

 установить точку буксировки ЭРЭ в центре элемента: RB> Setup> Center>OK 
 щелкнуть LB в центре элемента X1, переместить курсор в точку 135/95 (контроль 
по координатам в строке статуса) и щелкнуть LB – разъем займет ту же позицию; 

 для фиксации разъема на ПП щелкнуть LB на пиктограмме  и в любом месте 
разъема – его контур изменит цвет, что означает фиксацию X1. 

2. Ручное размещение элементов   (режим XY Location):  
 привязать точку буксировки ЭРЭ к точке, указанной при его создании, щелкнув RB 
в центре экрана и щелкнув LB на строках Setup>Origin>OK; 

 щелкнуть LB на Place Components>XY Location и перейти в окно Place Component; 
 установить все ЭРЭ, используя таблицу 20. 

3. Ручное размещение элементов   (режим Move Comp):  
 после: AutoPlace>Unplace>ALL Components аннулировать результаты размещения; 
 щелкнуть RB в центре экрана и выбрать строку Move Comp Mode; 
 используя таблицу 20, установить все элементы на ПП (для установки элемента R1: 
щелкнуть LB и RB в центре R1, выбрать Piviot>90, круговым движением курсора 
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по часовой стрелке развернуть R1 на 90 градусов, щелкнуть LB, и, перместив кур-
сор в точку 135/85, снова щелкнуть LB) 

3. АВТОМАТИЧЕСКОЕ  РАЗМЕЩЕНИЕ  
 после: AutoPlace>Unplace>ALL Components аннулировать результаты размещения; 
 задать область запрета установки ЭРЭ вокруг монтажных отверстий: после De-

fine>Keepout>ByCoordinates  установить поля: Keepout ID=Keep1, Type=Place,  Out-
line=Rectangle , XL=111.25, YL= 61.25,  XH= 118.75, YH= 68.75 и щелкнуть LB на 
кнопке Apply (так же задать область Keep2, изменив XL=151.25 и XH= 158.75) 

 разместить большие ЭРЭ (DD1 и DD2): AutoPlace >InitPlaceLargeComponents>OK; 
 разместить остальные ЭРЭ: AutoPlace > InitPlace Small Components > ALL>OK. 

4. ОПТИМИЗАЦИЯ РАЗМЕЩЕНИЯ  
1. Режим расталкивания компонентов демонстрируем  на текущем примере:  
 щелкнуть RB в любой точке ПП – и в меню выбрать строку Push Comp Mode; 
 щелкнуть LB в центре L1 и, перемещая L1 вверх, наблюдать за эффектом  растал-
кивания элементов. 

2. Взаимная перестановка ЭРЭ. 
Полученное в пункте 3 размещение является уже оптимальным ввиду малой раз-

мерности проекта. СДС полученного размещения (514 мм) показывается в последней 
строке отчета (Tatal Length) после: Report > PlaceStatus.  Для иллюстрации процедуры 
взаимной перестановки ЭРЭ поменяем вручную местами элементы R1 и R3 и восста-
новим исходное размещение автоматически. Ручной обмен выполним этапами: 
 щелкнуть RB в любой точке ПП – и в меню выбрать строку Trade Comp Mode; 
 щелкнуть LB в центре элементов R2 и VT1 -  элементы поменяются местами и 
длина связей станет равна  555 мм; 

Зафиксируем все ЭРЭ кроме R1 и R3 и выполним  оптимизацию размещения этапами: 
 после AutoPlace>Interchange Component установить лишь флажок Small и нажать OK; 
 дождаться окончания процедуры перестановки ЭРЭ и после Report> PlaceStatus 
проверить, что поле Tatal Length показывает прежнее значение CDC (514 мм). 

5. РАЗМЕЩЕНИЕ В «КОМНАТЫ»  
Создадим кластер CL1 из элементов C1, C2 и VT1 в и разместим их в комнату 

Room_1. Остальные элементы объединим в кластер CL2 и разместим их в комнату 
Room_2. Размещение начнем в редакторе РСВ загрузкой проекта Test-K. 
1. Перейти в режим размещения Specctra и выполнить подготовительные операции: 
 показать обозначения ЭРЭ: View>Labels>RefDes>OK и вписать всю ПП в экран; 
 после Rules>PCB>Spacing установить поле ALL = 0.2 и щелкнуть LB на кнопке OK 

– установлен глобальный зазор между всеми ЭРЭ на ПП, равный 0,2 мм; 
 командой Autoplace >Setup установить сетку PCB Placement Grid = 1,25 мм и щелк-
нуть LB на кнопке OK; 

2. Сформировать комнаты на ПП этапами: 

 после Define>Room>DrawMode щелкнуть RB в любой точке ПП и в открывшемся 

контекстном меню выбрать строку Set Pointer Snap Grid – откроется меню установ-



 50

ки сетки для пера рисования полигона для комнаты, в которой необходимо устано-
вить поле Snap Grid =1.25 и щелкнуть LB на кнопке OK; 

 щелкнуть LB в точках: 110/60, 110/100 и 125 /100 - щелкнуть RB и, выбрав строку 
Define Polygon As Room, ввести имя комнаты Room_1, установить флажок в строке 

 и щелкнуть LB на кнопке OK – построена 1-я комната в слое TOP; 

 при аналогичном формировании комнаты Room_2  указать точки: 125/60, 125/100  

и  160 /100 и слой � 

3. Сгруппировать элементы C1, C2, VT1 в кластер CL1: после Select> Components> Sel-
CompMode щелкнуть LB по этим ЭРЭ, выполнить команду Define>Claster> Selected, и 
в поле ClasterID ввести имя 1-го кластера (CL1) и щелкнуть LB на кнопке OK; 

4. Аналогично построить кластер CL2, включив в него остальные ЭРЭ (кроме X1). 
5. Задать область запрета установки элементов вокруг монтажных отверстий этапами: 

 после Define>Keepout>DrawModeпо аналогии с п.2 установить шаг сетки рисова-

ния полигона =1,25 мм; 
 щелкнуть LB в точках: 110/60, 110/70 и 120 /70 - щелкнуть RB и, выбрав строку 

DefinePolygonAsKeepout, ввести имя зоны запрета Keepout1, установить флажок в 

поле  и щелкнуть LB на кнопке OK – зона готова; 

 аналогично построить вторую зону запрета вокруг правого монтажного отверстия.   
6. Задать вертикальную ориентацию, для R1, R2, R3, VT1 и C2. Например, для задания 

ориентации для С2 после Rules> Component >Permitted Orientation – щелкнуть LB на 
кнопке Pick Component, имени C2, кнопке OK, установить оба флажка в полях Verti-

cal панелей Front и Back и щелкнуть LB на кнопке Apply � 

7. Задать сторону Front (Back) установки ЭРЭ внутри 1-ой (2-ой) комнаты командой: 
Rules >Room >ALL Components>PermittedSides >PickRoom >Room_1 > 
OK >Front >Apply >OK>PickRoom>Room_2> OK>Back>OK 

8. Определить правила размещения ЭРЭ внутри 1-й и 2-й комнаты этапами: 
 после Rules>Room>Contens>Pick Room>Room_1>OK –появится имя 1-й комнаты; 
 установить флажок Hard-Bound Incl CompList, в левом верхнем окне щелкнуть LB 
на имени CL1 – ЭРЭ кластера CL1 будут жестко связаны с комнатой Room_1; 

 снять флажки с остальных полей и щелкнуть LB на кнопке Apply 
 после Pick Room> Room_2 > OK – в верхней строке появится имя 2-й комнаты; 

 в левом верхнем окне щелкнуть LB на имени CL2 и  на кнопках � и . 

9. Разместить ЭРЭ DD1 и DD2: AutoPlace > InitPlace Large Components>OK; 
10. Разместить остальные ЭРЭ: AutoPlace > InitPlace Small Components > ALL>OK. 
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42. ГИП - режим трассировки         

I. РУЧНАЯ ТРАССИРОВКА  
Переход в режим ручной трассировки проекта Test-R в среде ГИП  программы 

SPECCTRA выполняется так же,  как он описан в пункте 1 раздела 41, однако имя про-
екта Test-K здесь заменяется на Test-R, а команда Place > Autoplacement заменяется ко-
мандой Route > Autorouters. Ручная трассировка проекта выполняется этапами:  
1. Установить шаг сетки трассировки = 1.25 мм: по команде  AutoRoute>Setup (в 

окне Routing Setup) щелкнуть LB по кнопке Setup Wire Grid и в окне Wire Grid уста-
новить Grid X = Grid Y =1.25 и щелкнуть LB на Apply>OK>OK. 

2. Установить шаг сетки для переходных отверстий = 1.25 мм этапами: 
 после AutoRoute>Setup щелкнуть LB по кнопке SetupViaGrid - откроется окно Via Grid; 
 установить поля GridX=GridY=1.25 и щелкнуть LB на Apply>OK>Hard>OK. 

3. Показать сетку трассировки: после  View>Layers щелкнуть LB на Wire Grid>Close. 
4. Построить зону трассировки этапами: 
 после Define>Fenсe>DrawMode  щелкнуть RB в центре ПП и в окне Draw Fence 
щелкнуть LB на строке Set Pointer Snap Grid  – откроется окно «Snap Grid»; 

 ввести шаг сетки 1.25 и щелкнуть LB на кнопках Apply>Ok; 
 щелкнуть LB в точках перегиба зоны трассировки: 111,25/68,75 ,111,25/98,75 

,158,75/98,75 ,158,75/68,75 ,151,25/68,75 ,151,25/61,25 ,118,75/61,25 , 118,75/68,75 и 
111,25/68,75 – щелкнуть RB и выбрать строку Define Polygon As Fance. 

5. Выполнить автоматическую трассировку цепей питания этапами: 
 после Select>Nets>By Class>PWR>Apply>OK  – цепи питания будут выделены; 
 после Autoroute> Route> OK – цепи питания будут разведены; 
 после Select > Nets > Unselect ALL  –  будет снято выделение с цепей питания. 

6. Удалить проводники, заключив их в прямоугольник командой Delete Segment, – 
кнопка . (или щелкая LB в режиме Delete Segment на удаляемых проводниках) 

7. Выполнить начальные операции для разводки цепи A4  в интерактивном режиме: 
 после Select>Nets>ByList>A4>FitSelection – цепь A4 подсветиться и все ее контакты 
впишутся в экран  (снять выделение можно по  Select > UnSelect All Routing Objects) 

 щелкнуть LB на кнопке  Edit Route –   в строке статуса появятся слова Edit Route;  
 щелкнуть  RB  в центре экрана  и выбрать строку Setup – откроется окно Interactive 

Routing Setup;  
 на вкладке PointerStyle установить: PointerStyle=90O – разрешить показ ортогональ-
ных направляющих линий при разводке;   SnapAngle=90O – разрешить проведение 
только ортогональных трасс;   снять флажок в поле Meter и  щелкнуть LB на OK;  

8. Показать названия элементов и контактов командой: View > Labels>ViewLabels> Ref 
Des and Pin Ids>Apply>OK. 

9. Развести участок цепи A4 от контакта DD2/1 до  DD2/8 в интерактивном режиме: 

 щелкнуть LB на кнопке  –   в строке статуса появится сообщение Edit Route;  
 перевести курсор на контакт DD2/1 –  он примет форму карандаша;  
 щелкнуть LB – появятся направляющие линии, а слой TOP станет активным; 
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 щелкнуть LB в точке 120/90, и нажать F5  –  будет построен горизонтальный про-
водник, на ПП установлено ПО и текущим станет слой Bottom;    

 щелкнуть LB в точке 120/82,5, и нажать клавишу F6 (или дважды щелкнуть LB) – 
построен вертикальный проводник и установлено второе переходное отверстие на 
ПП, а текущим станет слой Top;  

 щелкнуть LB на контакте  DD2/8 – требуемый участок цепи A4 построен. 
10.  Построить остальные проводники  цепи A4 в интерактивном режиме этапами: 
 щелкнуть LB на контакте DD2/8  и далее в точках: 138,75/82,5, 138,75/83,75, 

147,5/81,25  и  147,5/85  –  построена цепь между контактами DD2/8 и  DD1/12; 
 нажать на клавишу F5 – текущим станет слой Bottom; 
 щелкнуть LB на контактах  DD1/12 и  DD1/13 – цепь A4 построена. 

11. Переместить проводники цепи А4, подсоединенные к контакту DD2/8, вниз: 
 щелкнуть LB на кнопке  – в строке статуса появится сообщение Move. 
 щелкнуть LB в точке: 130/82,5 , перемещать курсор вниз до препятствия, –  щелк-
нуть LB, –  проводник перенесен с сохранением контакта;  

 щелкнуть LB в точке: 122,5/82,5 , перемещать курсор вниз до препятствия, –  
щелкнуть LB, –  проводник перенесен с сохранением контакта. 

12. Восстановить топологию трассы A4 методом спрямления трасс: 
 щелкнуть LB на кнопке  – в строке статуса появится сообщение Critic Route; 
 щелкнуть LB в центре каждого нижнего проводника – топология восстановлена. 

13.  Построить остальные трассы проекта. Например,  цепь A1 трассируется этапами: 
 после Select>Nets>By List>A1>Fit Selection –и все контакты A1 впишутся в экран; 
 снять выделение командой  Select > UnSelect All Routing Objects; 
 дальнейшие действия выполнять, придерживаясь методики пункта 7. 

14.  Изменить ширину проводника, подключенного к контакту DD2/1 c 0.25 мм на 0.7 
мм и обратно этапами: 

 щелкнуть  RB  в центре экрана  и выбрать  строку Change Wire Mode, далее установить  
Wire Width = 0.7 мм и нажать Apply (окно Change Wire Setup останется на экране); 

 щелкнуть LB на заданном проводнике – ширина станет равной 0,7 мм; 
 для восстановления исходной ширины установить  Wire Width = 0.25 мм,  нажать 
кнопку Apply  и щелкнуть LB в центре того же проводника; 

 для выхода из режима: щелкнуть  RB  в центре экрана  и щелкнуть LB на Cancel. 
15.  Вывести отчет о цепях, включенных в классы, командой Report > Classes 

II.  АВТОМАТИЧЕСКАЯ ТРАССИРОВКА  
Переход в режим автоматической трассировки проекта Test-R из программы PCB в 
программу SPECCTRA выполняется этапами:  
 в редакторе PCB загрузить файл Test-R, после Place>Autorouter установить значе-
ние поля Autorouter = SPECCTRA и щелкнуть LB на кнопке Command Line. 

 установить флажок в поле Quit when done, и нажать кнопку OK; 
 щелкнуть LB на кнопке Edit As Text и в открывшемся окне ввести следующие ко-
манды Do-файла (без комментариев, указанных курсивом): 
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circuit class SIG (use_via V1p4_0p8C) для цепей класса SIG использовать ПО V1p4_0p8C 
circuit class PWR (use_via V1p4_0p8C) для цепей класса PWR использовать ПО V1p4_0p8C 
smart_route (min_via_grid 1.25) установить сетку трассировки с шагом 1,25 мм 
smart_route (min_wire_grid 1.25) установить сетку ПО с шагом 1,25 мм 
write session $\Test-R.ses записать результат в файл Test-R.ses 
После щелчка LB на кнопке «Start» будут автоматически выполнены шаги: 1) переход 
в программу SPECCTRA,  2) автоматическая трассировка проекта; 3) возврат в редак-
тор PCB, причем результирующему проекту будет присвоено имя RTest-R. 
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43. Ручная корректировка трасс          
Трасса, реализующая электрическую цепь (NET) на ПП рассматривается программой 
Specctra как совокупность отдельных объектов – маршрутов или проводников (Wires). 
Маршрут подсвечивается после щелчка LB в любой его точке, выполняемого в режиме 
Select Wires, который устанавливается после: Select > Wire> Sel Wire Mode . 

Для иллюстрации процедуры ручной корректировки трасс: 
1. Удалиь все ранее построенные трассы:  Edit > Delete Wires > ALL Wires > Yes. 
2. Построить в слое TOP участок трассы A4 между контактами DD2/1 и  DD2/8. С 

этой целью после  Edit Route щелкнуть LB на контакте DD2/1, далее в точках: 
120/90, 120/82,5 и на контакте  DD2/8. 

3. Довести трассу A4 до контакта DD2/2, для чего щелкнуть LB на контакте DD2/2, и 
в точке: 120/88,75 (рис.45) 

4. Переместить вертикальный участок трассы нижнего маршрута влево на один дис-
крет. С этой целью: перейти в режим сдвига трасс (кнопка Move на ПИ) и щелкнуть 
LB в центре вертикального проводника и в любой точке соседней дискреты. Отме-
тить, что произошел перенос только нижнего участка вертикального проводника, 
принадлежащего нижнему маршруту (рис.  46).  

5. Выполнить «фаску под 45О» для нижнего маршрута этапами: 
 разрешить выполнение фаски под 45О, для чего: щелкнуть  RB  в центре экрана  и 
выбрать строку Setup и в окне Interactive Routing Setup; установить SnapAngle = 45O 
и щелкнуть LB на OK; 

 щелкнуть LB на кнопке  и в точках 118,75/82,5  и  121,25/85  (рис.  47); 
 восстановить прямой угол, щелкнув LB в точках 120/83,75  и  118,75/82,5 (рис.  46). 

6. Ввести дополнительную вершину в центр вертикального проводника нижнего маршрута: 
 щелкнуть LB на кнопке   (режим Cut Segment Mode)  
 щелчком LB в точке  118,75/86,25  установить дополнительную вершину; 
 с целью проверки введения дополнительной вершины переместить нижний уча-
сток вертикального проводника на три дискрета вправо, щелкнув LB на кнопке 
Move ПИ и в точках  118,75/85  и  12125/85  (рис.  48). 
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44. Выполнение отдельных элементов ПП        
1. Предтрассировка шин питания в PCB. 
1. Выполнить предварительное построение шин в программе PCB этапами:  
  в редакторе PCB загрузить файл Test-R и установить текущим сигнальный набор 
слоев: Options>Layers>Set >Signal Layers>EnableLayers>Close; 

 сделать текущим слой Bottom и показать связи цепи GND: Edit>Nets>Gnd>Show>Close 
 по команде Route>Manual, последовательно щелкая LB в точках 115/76,25  115/72,5  

145/72,5  145/97,5, построить часть цепи GND – щелкнуть RB; 
 удалить отрезок проводника примыкающий к контакту, для чего: после Edit >Select 
щелкнуть LB и RB в точке  115/73,75 и нажать клавишу Delete; 

 изменить ширину проведенной трассы до 1.5 мм, щелкнув LB и RB в точке 120/72,5 
трассы и, выбрав строку Properties, установить поле Width=1.5 и нажать OK.  

 аналогично построить шину цепи +5B, проводя ее в слое TOP по точкам: 125/90; 
125//93,75; 155//93,75, после чего удалить отрезок,  примыкающий к контакту и из-
менить ширину оставшегося проводника до 1.5 мм; 

    
Рис.45 Рис. 46 Рис. 47 Рис. 48 

2. Защитить цепи GND от ее перетрассировки в программе Specctra этапами. 
 после Edit>Select>Edit>Nets>GND щелкнуть LB на кнопках Edit и ADD; 
 в окне Place Attribute выбрать Router>Ripup, ввести Value=No и нажать 

OK>OK>Close (аналогично защитить цепь +5B); 

3. После: elect>Route>Autorouter>SPECCTRA>DoWizard>AutoCreateDoFile>OK>Start>Да 

– будет выполнена трассировка в SPECCTRA с возвратом в PCB.   (protect net gnd) 
2. Предтрассировка шин питания в SPECCTRA. 
1. В редакторе PCB загрузить проект Test-R и запустить на выполнение программу 

Specctra, приняв в качестве Do-файла текст из табл.23. 
2. Построить шину +5B шириной 2 мм этапами: 
 после Select > Nets > By List >+5B >Fit Selection –контакты цепи +5B впишутся в экран; 
 перейти в режим Edit Route , щелкнуть LB в точках 127,5/97,5;  127,5/93,75; 155/93,75, 
щелкнуть RB и далее щелкнуть LB на строке Done – часть трассы +5B построена; 

 в режиме Delete Segment  удалить вертикальный проводник построенного маршрута; 
Таблица 23 

circuit class SIG (use_via V1p4_0p8C) 
circuit class PWR (use_via V1p4_0p8C) 
grid wire 1.25 (direction y) (offset 0) 
grid wire 1.25 (direction x) (offset 0) 
grid via 1.25 (direction y) (offset 0) 
grid via 1.25 (direction x) (offset 0) 
vset system Grid on 

 mode edit fence 
area init_pt 111.25 68.75 
area add_pt 111.25 68.75 
area add_pt 111.25 98.75 
area add_pt 158.75 98.75 
area add_pt 158.75 68.75 
area add_pt 151.25 68.75 

area add_pt 151.25 61.25 
area add_pt 118.75 61.25 
area add_pt 118.75 68.75 
area add_pt 111.25 68.75 
area close_poly 
fence digitized 
repaint 
stop 
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 для изменения ширины шины: щелкнуть RB на ПП, в меню INTERACTIVE 
ROUTING MENU выбрать строки Change>ChangeWireWidthMode, установить Wire 
Width = 2 и щелкнуть LB на кнопке Apply  и в любой точке шины – шина построена. 

3. Так же построить шину GND в слое Bottom между точками 137,5/65;  137,5/65. 
4. Защитить шины от перетрассировки в автоматическом режиме этапами: 
 после Edit>{Un}Protect>WiresByNet>ByList>Protect с помощью клавиш CTRL и 

LB оставить в списке цепей выделенными только цепи +5B и GND; 
 щелкнуть LB на кнопке Close – факт защиты будет подтвержден тонкими белыми 
полосками вдоль шин. 

5. Выполнить далее трассировку в автоматическом режиме: Autoroute >Route > OK. 
6. Записать результаты на диск и вернуться в PCB после: File >Quit>Save And Quit 
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45. Трассировка МПП           

Выполним трассировку проекта MPP-R в слоях Top, Bottom, Int2 и Int3 этапами: 
1. Вызвать редактор РСВ и открыть проект MPP-R.PCB 
2. Запретить для трассировки слои Int1 и Int4 командой:  

Options >Layers > Int1 >Disable > Int4 >Disable. 

3. Выполнить трассировку МПП программой SPECCTRA,  используя Do-файл: 
circuit class SIG (use_via MPO)    circuit class PWR (use_via MPO) 
smart_route (min_wire_grid 1.250000)  smart_route (min_via_grid 1.250000) 
write session $\Test-R.ses 
4. Сохранить файл под именем MPP-T.PCB. 

 

46. Выбор символа из проекта в библиотеку        

Рассмотрим выбор в библиотеку New символа 4AND-NOT из проекта Test.SCH 
1. В редакторе Schematic отключить от проекта все библиотеки. 
2. Командой Library > New создать и подключить новую библиотеку NEW. 
3. Записать символ  4AND-NOT схемы Test.SCH в библиотеку New этапами: 
 загрузить файл Test.sch , щелкнуть LB и RB в центре символа 4AND-NOT и в меню 
выбрать строку Explode – символ преобразуется в формат программы Symbol Editor; 

 выделить все элементы символа в режиме Edit > Select и командой Library > Symbol 
Save As записать его в библиотеку New под именем 4AND-NOT; 

 

47. Программа Design Manager       

Окно программы Design Manager (Менеджера проекта) открывается в редакторе 
РСВ после  View > Design Manager.  Верхняя строка менеджера представляет панель 

инструментов. Кнопка  этой панели переключает работу менеджера в режим анали-
за цепей проекта (режим цепей). Соседняя кнопка –  – предназначена для работы в 
режиме компонентов. Далее следуют три кнопки, работающие одинаково в обоих ре-
жимах работы менеджера – кнопка Zoom обеспечивает вписывание в экран выбранно-
го объекта, кнопка Filter позволяет ослабить видимость не выбранных объектов (коэф-
фициент ослабления задается в поле Filter Dim), наконец, кнопка Quick Select – выделя-
ет выбранный объект (как по команде Edit>Select).    

1. Режим цепей. В этом режиме открываются три окна, представляющие: а) пол-
ный список цепей проекта (среднее окно - Nets), б) разбиение цепей по классам (верх-
нее окно – Net Classes) и в) список контактов выделенной в окне Nets цепи (Nodes on 
Net). Выполним для примера просмотр связей всех цепей проекта Test-R этапами: 
 в редакторе РСВ открыть Менеджер проекта, открыть файл Test-R.PCB, вписать 
проект в экран: View>Extent и показать все связи: Edit>Nets>SelectAll>Show>Close; 

 включить фильтр, утопив кнопку  , и установить поле Filter Dim =75; 
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 в окне Net Classes выбрать строку All Nets и, щелкая LB на строках окна Nets, 
наблюдать за конфигурацией и манхеттеновой длиной цепей проекта. 
2. Режим компонентов. В этом режиме открываются три окна, представляющие 

полный список компонентов (среднее окно - Components), их разбиение по комнатам 
(верхнее окно – Rooms) и список цепей, подключенных к контактам выделенных в 
окне Components компонентов (Component). Выполним просмотр поочередно всех 
компонентов проекта Test-R этапами: 
 переключиться в режим компонентов; 
 щелкая LB на строках окна Components, наблюдать за положением ЭРЭ на ПП. 
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48. Выпуск конструкторской документации     

1. Подготовка «Перечня элементов» выполняется этапами: 
 запустить редактор РСВ и открыть файл Test-R.PCB 
 заменить редактор Notepad на Word-97: после Options >Configure установить File 

Viewer=C:\ProgramFiles\Microsoft Office\Office\ Winword.exe  и нажать кнопку OK; 
 после File > Reports  в одноименном окне щелкнуть LB на кнопке Filename, в ко-
мандной строке ввести имя формируемого «Перечня» – TEST и щелкнуть LB на 
кнопке «Сохранить» – произойдет возврат в окно File Reports; 

 щелкнуть LB на кнопке  Clear ALL и установить флажок в поле «Attributes  (atr)»; 
 щелкнуть LB на строке «Separated List»; в окошке «List Separator» выбрать символ 

«точка с запятой» и щелкнуть LB на кнопке Generate – будет построен перечень 
ЭРЭ (табл.24)  в формате и в редакторе Word-97; 

 выделить строки, относящиеся к «Перечню элементов» (таблица 24) и выполнить 
команду: Таблица > Преобразовать в таблицу – откроется одноименное окно; 

Таблица 24 Таблица  25
"C1";"K10-43A";"4700p";"ОЖО.60.17 ТУ"  "C1" "K10-43A" "4700p" "ОЖО.60.17 ТУ"  
"C2";"K73-15";"1.5*160";"ОЖО.60.17 ТУ" "C2" "K73-15" "1.5*160" "ОЖО.60.17 ТУ"  
"DD1";"K511PU2";"";"" "DD1" "K511PU2" ""  
... ... ... ... ... 
"X1";"ON-KS-10";"";"" "X1" "ON-KS-10" ""  

 установить флажок в поле  Точка с запятой и щелкнуть LB на ОК – таблица 25; 
 выделить всю таблицу, выполнить команду Правка > Заменить и в открывшемся 

окне ввести в поле  «Найти» символ " (двойной апостроф), в поле  «Заменить на» - 
ввести символ «пробел» и последовательно щелкнуть LB на кнопках  «Замнить 
все», «Да» и «Нет» – получена требуемая заготовка  «Перечень элементов». 

2. Подготовка «Таблицы отверстий». 
 в редакторе P-CAD PCB открыть файл TEST-T.PCB и подготовить информацию для 
таблицы отверстий:  File > Print >Drill Symbol > Automatic Assign >Close >Close. 

 командой View>DocToolToolbar активизировать панель инструментов Doc Tool 

Toolbar и щелкнуть LB на кнопке � (первая слева) и в любой точке 

рабочего поля – откроется окно Place Table; 
 установить: Table Type = Drill Table,   Table Name = Таблица отверстий,   Text Style = 

2p5,   Line Width =0.1  и щелкнуть LB на кнопке OK и в точке рабочего поля PCB 
расположения таблицы – получена искомая таблица. 

3. Подготовка Gerber – файлов выполняется этапами: 
1. Открыть окно File Gerber Out командой File>Export > Gerber File>Print>Drill Symbol; 
2. Перейти в окно Setup Output Files, щелкнув LB на одноименной кнопке и подготовить вы-

ходные файлы с расширениями TOP и BOT – для Gerber-файлов слоев TOP и BOT этапами: 
 в поле File Extention  ввести расширение TOP, в столбце Layers нажать на строку 

TOP и щелкнуть LB на кнопке ADD – в списке Output File появится имя Test-T.TOP 
выходного Gerber-файла для слоя TOP; 



 60

 аналогично ввести имя Test-T.BOT выходного Gerber-файла для слоя BOTTOM; 
3. Сформировать информацию о топологии в файлах TEST-T.TOP и TEST-T.BOT: 
 в списке Output File щелкнуть LB на строке Test-T.TOP – строка (и слой) выделятся; 
 для включения информации о КП установить флажки Pads и Vias и нажать Modify; 
 щелкнуть LB на строке Test-T.BOT и,  установив флажки Pads и Vias,  нажатьModify; 
 сбросить флажок в поле Drill Symbols, проверить путь к папке проекта в окне 

Output Path и щелкнуть LB на Close – произойдет возврат в окно File Gerber Out. 
4. Щелкнув LB на кнопках Apertures>Auto>Close, сгенерировать апертуры плоттера. 
5. Установить формат Gerber-файла, щелкнув LB на кнопках: Gerber Format >Millime-

ters >4.4 >RS274X >Close и выполнить генерацию Gerber-файлов, щелкнув LB на 
кнопках: Set ALL и Generate Output Files>Close. 

6. Выполнить генерацию Gerber-файлов для сверлильных автоматов этапами: 
 после File >Export>N/C Drill>Setup Output Files перейти в окно Setup Output Files;   
 установить File Extension = DRM  для металлизированных (и File Extension = DRN 
для не металлизированных) отверстий, далее щелкнуть LB на кнопках Plated Holes 
(Non-plated Holes),  Set ALL и ADD – в списке Output File появится имя 1-го (2-го) 
Gerber-файла Test-T.DRM (Test-T.DRN); 

 установить  путь к папке проекта в окне Output Path, щелкнуть LB на кнопках 
Close>Tools>Auto>Close – будут сгенерированы диаметры отверстий; 

 щелкнуть LB на кнопке N/C Drill Format  и строках: Millimeters>ASCII 
None>Leading>Close – будет задан стандартный формат файла сверления; 

 после: Generate Output Files>Close –  будут сформированы файлы сверления.  

4. Проверка Gerber – файла выполняется в программе Camtastic! 2000 этапами: 
1. Загрузить Camtastic!2000 и после File>Import > Gerber установить путь к папке с 

файлом Test-T.TOP и нажать кнопку Открыть – откроется окно Import Gerber File. 
2. Настроить параметры входного Gerber-файла этапами: 
 щелкнуть LB на кнопке Setting, установить поля: Integer=4, Decimal=2, и последо-
вательно щелкнуть LB на строках: Metric >Absolute > Leading > OK; 

 щелкать LB на кнопке Gerber пока на ней не появится надпись Gerber RS-274-X; 
 проверить наличие строки Auto-Detect Apertures в поле Apertures Wizzard и щелк-
нуть LB на кнопке OK – будет выполнена загрузка топологии слоя TOP платы. 

3. Аналогично загрузить файл Test-T.BOT. 
4. Настроить параметры файла Test-T.DRM с графикой металлизированных отверстий: 
 после File>Import > Drill установить путь к папке с файлом Test-T.DRM и щелк-
нуть LB на кнопке «Открыть» – откроется окно Import Drill Data. 

 щелкнуть LB на кнопке Units,  присвоить: Integer=4, Decimal=2 и щелкнуть LB на 
строках: Metric >Absolute > Leading > OK – произойдет загрузка металлизирован-
ных отверстий печатной платы, наложенных на совмещенную топологию ПП; 

5. Аналогично загрузить файл Test-T.DRN. 
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49. Дополнительные сервисные функции      

1. Настройка путей к папкам пользователя 
Настройка пути по умолчанию к папке C:\DP,  устанавливаемому при вызове про-
граммы Schematic из папки C:\Program Files\Pcad 2002 выполняется этапами:  

 в программе Library Executive выполнить команду Utils>Customize; 
 щелкнуть LB на кнопке ADD и, используя клавиши Browse (просмотр),  установить 
поля: Menu Text = Sch; Initial Directory = C:\DP;  Command = C:\Program Files\Pcad 2002; 

 щелкнуть LB на кнопке OK –  появится дополнительная панель инструментов с 
кнопкой вызова программы Schematic;  

 проверить установку пути, щелкнув LB на кнопке Sch новой панели инструментов, 
– путь C:\DP  появится в строке приглашения при выполнении команды File>Open. 
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LB – левая клавиша мыши 
RB – правая клавиша мыши 
ПП – печатная плата 
МПП – многослойная печатная плата 
ЭРЭ – электрорадиоэлемент 
УГО – условное графическое 

обозначение 
ПМ – посадочное место 
ИМС – интегральная микросхема 
ПЭС – принципиальная 
    электрическая схема 
ПО – переходное отверстие 
ТЗА – таблица запросов 
ТОК – таблица отчетов о найденных       

компонентах 
DRC – Design Rule Checks (проверка 

правил проектирования) 
RB – правая клавиша мыши 
RB – правая клавиша мыши 
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ДОПОЛНИТЕЛЬНЫЙ МАТЕРИАЛ 
 

1. Как трассировать все цепи кроме цепей питания:  

 в программе Specctra выбрать Select>Nets>Select All 

 далее выбрать Select>Nets>By List;  

 при нажатом Ctrl щелкнуть LB на строчках +5V, GND; 

 щелкнуть LB на кнопке Close; 

 после Autoroute>Route>Ok будут разведены только сигнальные цепи;  
2. Что такое кластер?  

Кластер – это совокупность элементов проекта заданного пользователем типа. В качестве кри-
терия могут выступать следующие типы элементов:   

 floor plan (все элементы этого типа могут назначаться для размещения либо внутри, либо сна-
ружи комнаты),  

 Super (все элементы кластера этого типа имеют фиксированное взаимное расположение и 
фиксированную ориентацию внутри Super-кластера, образуя суперкомпонент),  

 Piggyback (элементам этого типа разрешено перекрывать друг друга в процессе размещения), 

 Super (все элементы кластера этого типа имеют фиксированное взаимное расположение и 
фиксированную ориентацию внутри Super-кластера, образуя суперкомпонент),  

 Super Piggyback (суперкомпонентам , составляющим этот тип, разрешено перекрывать друг 
друга в процессе размещения), 

3. Как избежать смещения элемента при его открытии из библиотеки?:  

 в редакторе Symbol Editor после Symbol>Open указать путь к требуемой библиотеке – от-
кроется ее оглавление: 

 выбрать строку с требуемым компонентом и нажать  Ok – элемент появится на поле черте-
жа, причем его точка привязки окажется в сетке с шагом 2,54 мм;  

 после Edit>Select All щелкнуть правой клавишей в центре рабочего поля и выбрав в от-
крывшемся контекстном меню строку Selection Point , щелкнуть LB в точке привязки эле-
мента; 

 после Edit>Cut вырезать элемент в карман; 

 установить шаг сетки = 1.25 мм и после установить элемент в новую рабочую сетку. 
4. Как ввести в дополнении к атрибуту «100 пФ» дополнительный атрибут вида: К10-17в-42-100 

пФ?:  
 дополнительный атрибут вводится аналогично атрибуту Value, однако вместо component>Value, 

указывается component>user-defined, причем в поле Name указывается, например, имя ValueTZ, а 
в поле Value вводится дополнительный атрибут К10-17в-42-100 пФ: 

 
5. Можно ли изменять стили текста для атрибутов у групп компонентов?:  
 можно только в редакторе PCB - для этого достаточно:  

 в редакторе PCB выделить требуемую группу компонентов, щелкнув на каждом из них 
левой клавишей мыши при нажатом CTRL,  

 правой клавишей мыши открыть контекстное меню и выбрать строку Properties, 

 в колонке Text Style строки RefDes указать новый стиль - готово 
 
6. Можно ли создавать и импортировать базы стилей текста?:  
 можно передавать стили текста из одного проекта в другой через шаблон или штамп. 
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7. Как заставлять функцию «Force Update» не изменять атрибуты проекта?:  
 Для этого достаточно после выделения требуемого элемента схемы, активизации команды 
Utils>Force Update и указания элемента для замены установить флажок Ignore Attribute From Li-
brary в правом нижнем списке опций окна Force Update 
 

8. Как создавать сложные КП с отверстиями не в центре?:  

Площадка Vos вида: (сетка = 0,25 мм) с внешним диаметром, равным  = 1.5 мм и диа-
метром внутреннего отверстия, равным  = 0.3 мм, смещенным относительно центра КП по оси 
Х на 0,5 мм и по оси Y на 0,2 мм , создается этапами: 

 после Options>Pad Style>Copy ввести имя Vos, и нажав OK>Vos>Modify (Complex), перейти в 
режим редактирования площадки; 

 установив поля: Layer = Top, Hole(Diameter)=0.3, Shape=Polygon и флажок в поле Hole (Plated) 
(есть металлизация), нажать Modify; 

 в открывшемся окне Polygon Pad Shape установить: флажок Regular Polygons , поле Sides=8  и 
поле Diameter=1.5mm 

 нажать кнопки Uodate и ОК 

 аналогичные операции выполнить для слоя Bottom – КП готова 
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